日曜日の朝、突然インターネットにつながらなくなり、ルーターを再起動したところ、MacとWin2000搭載のPCは問題なくつながるようになりました。しかし、XP搭載のPCだけがうまく動きません。サーバーとして利用しているのですが、8080番は開くのに、80番が開かないのです。また、8080番へのアクセス時間がそれまで以上にかかるようになりました。設定全てを見直しましたが、おかしなところは見つかりません。突然つながらなくなった理由も分からないので不安です。こういう場合は、何を調べればいいのでしょうか。わかりやすく説明しているHPを教えて下さい。よろしくお願いします。ルーターは オムロンの MR104FHPCは、イーマシーンズN2242 です。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2003/09/08 14:28:23
  • 終了:--

回答(5件)

id:Ryusei No.1

Ryusei回答回数31ベストアンサー獲得回数02003/09/08 15:47:23

ポイント16pt

そのルータがDHCPサーバ機能も提供していたなら、ルータの再起動時にDHCPサーバ機能が途絶え、その隙にWindowsXPがいい加減なIPアドレスを設定してしまい、ファイヤーウォールなどに拒絶されてしまうというシチュエーションがあります。コマンドラインからipconfigでXPマシンのIPアドレスを確認されてはいかがでしょうか?

id:nekogo

IPアドレスは、DHCPサーバーに割り振られないように、手動で設定してあります。ネットワークの設定は何度も見返していて、ルーターとの整合性はとれています。勝手にこの設定を書き換えたりもするんでしょうか。リンク先も良く読ませていただきますが、何かありましたらよろしくお願いします。

2003/09/08 15:54:23
id:sasada No.2

sasada回答回数1482ベストアンサー獲得回数1332003/09/08 16:14:28

ポイント16pt

http://www.hatena.ne.jp/1062998903#

日曜日の朝、突然インターネットにつながらなくなり、ルーターを再起動したところ、MacとWin2000搭載のPCは問題なくつながるようになりました。しかし、XP搭載のPCだけがう.. - 人力検索はてな

 URLはダミーです。

 質問文だけで、「これそ!!」という回答をするのが難しそうですので、質問を兼ねたアドバイスという事で回答させていただきます。

 次の回答者のために、可能なものだけでも情報を提供していただけると助かります。

 ネットワークの設定に不審な点が見られないのならば、WinXPのパソコン自体もしくは、そのWebサーバーに問題が有るのかもしれません。

 WinXPへのpingの反応速度はどうでしょう?

 XP上で(ping 127.0.0.1を)実行したときも不信な反応をしますか?

 他のパソコンからpingしたときはどうでしょう?

 他のパソコンからのpingが遅いなら、やはりルーターを含むLAN環境を疑った方が良いでしょう。

 次の回答者のために、ipconfigやtracertの情報(意図した設定と異なる点、反応スピード等)も ご紹介いただくことができれば、謎が減るかもしれません。(増えるかも)

 でも、pingがレスポンス良く帰ってくるようでしたら、Webサーバー、ファイアウォール、ウィルス対策ソフト等、他の要因を疑った方が良さそうです。

 httpのコネクトでポート8080とポート80を使用されているようですが、これはどちらもIISですか? ここで、どんな設定上の違いがあるのかで、原因究明が絞れるかもしれませんね。

 あと蛇足ながら、MSブラストなどの攻撃を受けていないか、確認された方が良いかもしれません。

id:nekogo

遅くなりましたが、WinXPからの127.0.0.1や127.0.0.1:8080は問題なく数秒で表示されます。

Macからだと、IPを直接打って、80番は開き、8080番は開きませんでした。午前中はダメだったんですが、夕方頃から、80番で外部からアクセスができているようです。

80番はTeveoいうライブカメラソフト、8080番はApacheで使用しています。

2003/09/09 01:59:32
id:ytate No.3

ytate回答回数4ベストアンサー獲得回数02003/09/08 18:23:26

ポイント16pt

http://www.omron.co.jp/ped-j/product/adsl/mr104fh/mr104fh.htm

MR104FH|製品情報|OMRON 電源機器

MR104FHにはファイアウォール機能がありますが、それが間違って働いていないでしょうか? 何らかのアクセスがうまくいかず、リトライを繰り返すと、DoS攻撃と勘違いすることがあると思います。ルータのログを確認してみてはいかがでしょう。

id:nekogo

ログは見つけたのですが、怪しいところはありませんでした。

2003/09/09 02:15:56
id:sinb No.4

sinb回答回数341ベストアンサー獲得回数102003/09/09 00:57:06

ポイント16pt

他のpcへの接続はできてるので、ルータは関係ないような気がするけど。

ファイアウォールの設定とかサーバーソフトの設定とかも見直されたのでしょうか?

私の使ってるproxyサフトには、port設定の項目があります。今は8080にしてます。見直して問題なければ、osかサーバーソフトの再インストールをお勧めしますが、簡単にはできないですよね。

(~_~)うーーん!

id:nekogo

XPの設定を全て消去してからやり直してみました。やっぱりどこかがまずかったみたいで、直ったみたいです。ありがとうございました。

2003/09/09 10:42:52
id:sasada No.5

sasada回答回数1482ベストアンサー獲得回数1332003/09/09 09:21:48

ポイント16pt

http://homepage1.nifty.com/usa01/teveo.htm

Teveo Live FAQ&トラブルシューティング&Tips - Mary's Room

 このシチュエーションですと、初期トラブルの症状は、ライブカメラが怪しいような。

 上記URLの「TeveoLive FAQ 【よくある質問】Q5」とか、参考にしてみてください。

 「午前中はダメだったんですが、夕方頃から、80番で外部からアクセスができているようです」とのことで、ルーター再起動の際にインターネット側のIPアドレスが変更になっている気配がします。 それが原因で、外部からのアクセスが一時不通になったのではないでしょうか。

 ルーターのグローバルIPアドレスが変わっていたとして、最悪48時間で(IXのルーティングが再設定されて)外部からのアクセスが正常化するはずです。様子を見てみましょう。

 …XPのIISサービスが開始になっていて、80ポートが競合しているなんてことは、流石にないでしょうね。

 あと「ping 127.0.0.1:8080」を打った後は、Apache(サービス)を停止/起動した方が良いです。

 それでLANの内外からポート8080のWWWにアクセスできるようになったら、解決ですね。

id:nekogo

ありがとうございました。

2003/09/09 10:44:10

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません