without-mysqlでVersion 4.1.2をインストールしてしまいました。再コンパイルせずにwith-mysqlにして、phpからmysqlを使用可能にする方法を教えてください。Redhat8.0Apache1.3Mysql4.017です。#windowsで言うところのdllはlinuxだとどこにあるのでしょうか?

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/02/10 11:37:20
  • 終了:--

回答(2件)

id:wm5775 No.1

wm5775回答回数351ベストアンサー獲得回数42004/02/10 13:27:47

ポイント25pt

#windowsで言うところのdllはlinuxだとどこにあるのでしょうか?

部分回答です。

linuxにおけるDLLに相当するファイルは

・lib*.a

・lib*.a.so

というファイルです。

どこにインストールされているかはシステムやアプリケーションによっても異なりますので、findコマンドなどで探されるとよいと思います。

find / -print -name lib*.a*

ですべてがリストアップされます。

id:takaswie No.2

takaswie回答回数17ベストアンサー獲得回数02004/02/15 02:29:13

ポイント25pt

php4の再コンパイルは避けられないと思います。

lddコマンドでライブラリは確認できます。

id:kunitz

なるほど、どうも

2004/02/15 02:56:23

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません