CGIが実行できません。Anfy2、ホームページ・ビルダーを使用。infoseek isweb(無料版)にアップロードしましたが、表示されません。ホームページビルダーのプレビューでは正常に動きます。classファイルを設定しろと注意がありますが、ぜんぜん分かりません。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/03/05 03:31:19
  • 終了:--

回答(5件)

id:nokonoko No.1

nokonoko回答回数213ベストアンサー獲得回数32004/03/05 03:47:02

ポイント50pt

どのCGIを設置しようとしてが動かないのかが分からないので少し答えようがないですが…

とりあえずファイルをアップロードするときのモード(アスキー・バイナリ)の設定は大丈夫でしょうか。

UPしたファイルのパーミッションの設定、フォルダの設置等は説明どおりにされているでしょうか。

classファイルを設定と注意されたのであれば設定が出来ていないと思うのでCGIの説明書なり配布HPの注意書きを読んでみて該当する個所がないかを探してみてください。

もしかしたら配布ページの質問コーナーで同じような質問があるかもしれません。

id:kabao2003 No.2

kabao2003回答回数99ベストアンサー獲得回数02004/03/05 04:20:31

ポイント100pt

http://penguinman.hp.infoseek.co.jp/sl1.html

藤原由美子スライドショー

まず、これはCGIでなくてJavaアプレットですね。

実際にそのページを見に行きましたが、

java.security.AccessControlException: access denied (java.net.SocketPermission hpad.www.infoseek.co.jp resolve)

というエラーが出ていますね。どうやらこのアプレットは画像ファイルにアクセスしているようですから、画像にアクセスしにいったときにこのエラーが出ているのではないでしょうか。なぜかというと、<applet>タグ内の<param>指定で、175.jpg、159.jpgなどと書いてありますが、これらのアドレスを直接入力して見に行こうとしても404エラーがでて見れないからです。

ここに解説があるようですが、英語ですね。

要するに<param>内を適切に設定すればいいわけですが、おそらく画像を適切にアップロードして、ファイル名を正しくimage1、image2、image3のところに書いてやれば、少なくともエラーは出なくなるんじゃないかと思いますよ。

id:sonosonosono No.3

sonosonosono回答回数3ベストアンサー獲得回数02004/03/05 07:39:01

ポイント100pt

CGIと言うから、パーミッションとかの問題かと思っていたら、ソースを見たら、Javaアプレットが動作していないということですね。

classファイルのアップロードし忘れでは?

アプレットのINTRODUCTIONを読んで、必要なclassファイルが何かを確認して、アップロードされているかを確認してみてください。

id:Gyokuran No.4

Gyokuran回答回数662ベストアンサー獲得回数02004/03/05 10:33:23

ポイント60pt

AnFade.classというファイルをメモ帳などのエディタで開いて眺めてみてはいかがでしょうか。

おそらくそこに画像ファイルの設置場所について記載されていると思うのですが。

id:yosiaki No.5

yosiaki回答回数96ベストアンサー獲得回数02004/03/05 11:28:22

ポイント60pt

anfyの説明があります。

これでもわからなければ

BBSへどうぞ。

id:mami55

上記の方々を含めありがとうございました。原因はビルダー2001のサイト転送・ページ転送機能では指摘のファイルがアップロードしない(設定が悪い?)という単純なものでした。FTPツールで個別にアップロードして解決しました。

2004/03/06 01:49:17

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません