NetscapeEnterpriseServer3.6x+Zolar5i+Oracle8.1.6の環境を作っています。

マニュアル通りobj.conf等の設定をしましたが、ウェブサーバ起動時に以下のメッセージが出て起動できません。
--
conf_init: Error running init function load-modules: dlopen of /opt/netscape/suitespot/nsapi/firstc.so failed (ld.so.1:ns-httpd: 重大なエラー: 再配置エラー: ファイル /opt/netscape/suitespot/nsapi/firstc.so: シンボル naed5ci: 参照されたシンボルがありません)
--
ldd /opt/netscape/suitespot/nsapi/firstc.so
で調べても、見つからないものはないようです。
どこが悪いのでしょうか?

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/08/25 11:29:58
  • 終了:--

回答(3件)

id:aki73ix No.1

aki73ix回答回数5224ベストアンサー獲得回数272004/08/25 11:47:52

ポイント40pt

えっと、それは、WebAuthを使用する設定になってるにもかかわらず、インストールしてないのではないでしょうか?

2. WebAuthインストールをご覧下さい

id:kmzc

WebAuthインストールに書かれていることは実施しました。(firstc.soとsecondc.soのコピー)

2004/08/25 12:33:54
id:aki73ix No.2

aki73ix回答回数5224ベストアンサー獲得回数272004/08/25 12:40:10

ポイント40pt

すみません、2回目です

そのメッセージの意味は

naed5ciがns-httpdを実行した時にfirstc.soの中にないということなのですが

ランタイムのリンカの検索パスの中に問題があるのだと思います

makefileの中味の指定パスが 実際のフォルダ構成と異なっていないか確認してみてください

naed5ciは DES56-bit 暗号化アルゴリズムのライブラリ関係のようなので、古いライブラリとして、別途入れないといけないのかもしれません

使用する暗号が設定で変更できるようならば新しいものに変えると解決する可能性があります

id:kmzc

なるほど、別途入れる必要があるのですね!

もうすこし他の方の意見も聞いてみようと思います。

2004/08/25 12:43:17
id:nkik No.3

nkik回答回数5ベストアンサー獲得回数02004/08/25 12:40:57

ポイント80pt

naed5ciが見つからないということなので、Oracle8.1.6のライブラリが足りないのではないでしょうか?

OracleClientパッチを確認の上、genclntshでライブラリを作り直すといいかもしれません。

id:kmzc

先ほどの方と同じで、ライブラリ足りない、ということですね。

OracleのCD-ROMを漁ってみようとおもいます。

どうもありがとうございました。

2004/08/25 12:44:17

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません