自宅サーバーを構築しているのですが、LAN経由ではtelnet、FTPなどすべて接続出来るのですが、グローバルIPで接続を試みるとすべて失敗します。NATの設定も間違いないですし、DHCPが自動的に割り当てないローカルIPをサーバーPCに割り当てています。他にチェックすべき点はどこでしょうか?

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/09/12 23:04:23
  • 終了:--

回答(4件)

id:caramelmilk1028 No.1

caramelmilk1028回答回数53ベストアンサー獲得回数02004/09/12 23:15:13

ポイント20pt

URLはダミーです。

ブロードバンドルータを使用していると思いますが、通常NATの設定とIPフィルタの設定が必要です。

NATの設定だけではインターネットからの要求はIPフィルタで遮断されてしまいます。

IPフィルタの設定を確認してみてください。

id:cblue1975

分かりました。早速確認してみます。

2004/09/12 23:21:22
id:html1983 No.2

html1983回答回数72ベストアンサー獲得回数02004/09/12 23:19:36

ポイント20pt

http://www.hatena.ne.jp/1094997863#

自宅サーバーを構築しているのですが、LAN経由ではtelnet、FTPなどすべて接続出来るのですが、グローバルIPで接続を試みるとすべて失敗します。NATの設定も間違いないです.. - 人力検索はてな

ダミーです

もう少しネットワークの構成を詳しく書かれたほうが

ほかの方も回答しやすいと思いますよ。

失敗とうはどういう状態ですか?

どのPCからグローバルIPで接続しようとされたのですか?

ローカルIPが振られたPCからでしょうか。

でしたら、ルーター(もしくはそれに相当する機器)のWANインターフェイスに

telnet/ftpしにいこうとしてるのかもしれません。

ためしに、ご自宅の外からグローバルIPにアクセスしてみて下さい。

ご友人に依頼するのもよいかもしれません。

id:cblue1975

すいません。サーバーの勉強始めたばかりで説明が不足しているかもしれません…。

外部PCからのアクセスですね。やってみます。

2004/09/12 23:23:39
id:CaTBy No.3

CaTBy回答回数8ベストアンサー獲得回数02004/09/12 23:20:50

ポイント20pt

http://www.airstation.com/

無線LAN総合情報サイト airstation.com | BUFFALO バッファロー

使用しているルータはどこのメーカーでしょうか?

私も自宅サーバーを構築していますが、その際の事ですが、アイオー・データ、バッファローのルータを使用している場合、LAN側からWAN側のIPアドレスを指定しても正しくアクセスする事が出来ませんでした。

現在はバッファローのルータなので、アイオーのルータの仕様は変わっているかもしれません。

もし、LAN側からWANのIPアドレスを指定して行っているのでしたら、職場やマンガ喫茶など別のネットワークからチェックしてみては如何でしょうか?

id:cblue1975

なるほど。先ほどのかたと同様のご指摘ですね。やってみます。

2004/09/12 23:30:51
id:soaler No.4

soaler回答回数73ベストアンサー獲得回数02004/09/12 23:28:19

ポイント20pt

自分でグローバルIPを入れても自サーバーが見えないという事ではないのですか?

それならプロクシを通さなければ見えませんよ。

id:cblue1975

回答ありがとうございます。

2004/09/12 23:35:37

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません