phpPgAdminをインストールしたのですが、しょっぱなからエラーが発生します。

Your PHP installation does not support PostgreSQL. You need to recompile
PHP using the --with-pgsql configure option.
というエラーなのですが。・・・。
絶対にapacheの再インストールはヤです!
どうにか設定ファイルの変更で対処する方法を教えてください。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/10/25 20:38:55
  • 終了:--

回答(2件)

id:esseesse No.1

esseesse回答回数192ベストアンサー獲得回数02004/10/25 20:45:00

ポイント25pt

こちらを参考にPHPを再コンパイルしてください。

apacheの再インストールより面倒かも。。。

とりあえず必要なオプションは、

--with-pgsql

です。

id:terukuji No.2

terukuji回答回数19ベストアンサー獲得回数02004/10/25 23:03:10

ポイント25pt

postgreをどうやってインストールしたのでしょうか?モジュールをダウンロードしてきたのですか?それとも、Linuxにデフォルトで付いているモジュールを使っていますか?それで対処方法がちがいます。phpの設定の問題です。

id:Tariq

ありがとうございました!

2004/10/25 23:31:06

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません