NT4.0のネットワークの設定でお尋ねします。


社内のネットワーク環境においての設定なんですが、
他の動作しているWindowsOSと同様に
I.Pアドレス、サブネットマスク、DNS、WINSの
設定を行っても、インターネットも見れないし、
他の社内のPCにもアクセスできません。
サーバのユーザー登録は済ませてあります。

確認項目を以下に。

・ヤフーのアドレスを直打ちし、接続を試みが失敗
・アダプタのテスト→エラー無
・他のPCからPINGも通らない。


何かしらご教示頂けますでしょうか

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/11/24 19:41:14
  • 終了:--

回答(11件)

id:sandaler No.1

sandaler回答回数671ベストアンサー獲得回数02004/11/24 19:49:54

ポイント50pt

どこにもPingが通らないようだと、まず疑ってみるのはハードウェアだと思います。

LANボードはエラー無しということでしたら、LANケーブルはどうでしょうか。

内部で切断されていたり、キチンと接続されていなかったりすることがありますよ。

すでにチェック済みでしたらすいません。

id:kimudon No.2

kimudon回答回数1909ベストアンサー獲得回数1712004/11/24 19:56:02

ポイント50pt

URLはダミーです。

LANケーブルまたはHUBポートのエラーは考えられないでしょうか?

現状で正常にネットワークに接続されているPCよりケーブルを外し、該当のNT4.0のPCに付け替え再起動してテストして見てください。

上記が見当違いでしたら申し訳ありません。

id:kuippa No.3

くいっぱ回答回数1030ベストアンサー獲得回数132004/11/24 20:21:31

ポイント50pt

設定があってるものとして考えます。

インターネットセキュリティやWinXPのファイヤーウオールなどが立っていませんか?

TCP/IP以外のプロトコルがインストールされていませんか?

LANケーブルがじつはクロスケーブルだったりしませんか?

ドメインの設定はあっていますか?

登録IPが重複してはいませんか?

PINGでループバック(127.0.0.1)はとおりますか?

慌てていませんか?

きっとお茶をのんでゆっくりすれば、ぁー間違ってたーってところが見えてくる気がします。

id:snitch No.4

snitch回答回数516ベストアンサー獲得回数92004/11/24 20:51:31

ポイント150pt

他のマシンと同じIPアドレスか同じマシン名になっていないでしょうか?

それでは、相互に通信できませんよ。

id:anesin

すみません。ひとつずつ回答し損ねてしまいましたので

まとめて回答させて頂きます。

○LANケーブル

正常に動作する端末のケーブルを

付け替えても変わりはありませんです。

また、ストレートケーブルに間違いはなさそうです。

○セキュリティ関連

 サービスパック6をあてたのみで。

 他は初期インストール設定となっております。

 他の接続PCに、ファイヤーウォールの設定はありませんでした。

○プロトコル

 NetBEUIが入っていたので

 消して動作確認してみましたが

 変わりはありませんでした。

○ドメインの設定

 このあたりが良くわからなくて

 申し訳ないのですが、

 内の会社では、ドメイン管理を

 行っているのかどうかがわかりません。

 ネットワークの設定を行う際、

 ワークグループの設定を行うのみで、

 他のPCに対し、ドメイン参加させる

 事は今までして来なかったので、

 良くわかってないのが実情です。

 DNSの設定も、本当に必要なのかさえ

 わかっておりません。

○IP重複

 社内のIP管理資料と、事前に

 PINGを飛ばすことで、重複は無いものとしました。

○ループバック

 127.0.0.1 はとおりました。

○マシン名

 マシンはすごく特殊な名前を入れてあるので

 かぶることは無いと思われます。

 (社も小さいですし、確認ができております)

○その他、確認できた事

 問題の端末から他の端末へPINGを飛ばそうとした際、

 「 Destination host Unreachable 」

 とメッセージが返ってきます。

 通常ですと、相手先が見つからない場合は

 「Request timed out, 」と

 返ってくるのが一般的だと思うので

 違いというとこの辺りでしょうか

2004/11/24 21:14:12
id:sandaler No.5

sandaler回答回数671ベストアンサー獲得回数02004/11/24 21:27:40

ポイント50pt

http://tooljp.com/qa/CE35552757EAC1DD492569F6001D5038.html

【Windows 2000】pingを実行すると"host destination unreachable"と表示されます。どういう意味ですか。 | TIPS , FAQ

Destination host Unreachableのエラーメッセージには、こちらのページが参考になるかもしれません。

デフォルトゲートウェイの設定が出来ていない可能性があります。

id:anesin

デフォルトゲートウェイの設定も

恐らくは問題ないと思われます。

○手持ち資料の信憑性について

手持ちの資料と、他の動作している端末約5台を

見た上での回答です。

その情報も1年くらい経過しているので

教えられた情報が間違っている場合には

今日に至るまでに何らかの不具合が生じている

だろうと思われるので、所持しているネットワーク関連の

情報については、問題は無いと思われます。

また、今回もその情報(I.P、サブネット、DNS、デフォゲートウェイ、WINS)を設定してあります。

2004/11/24 21:40:14
id:kensaito No.6

kensaito回答回数163ベストアンサー獲得回数42004/11/24 22:16:22

ポイント50pt

サブネットが違うネットワークに繋いでいると言うことはありませんか?

たとえば、192.168.0/24と192.168.1/24の2つのネットワークがある環境で、192.168.1/24のネットワークに、IPアドレス192.168.0.100の機器を接続しても、ルータを越えられないので、そのネットワークの外側(192.168.0/24)にはパケットが出ていきません。

もう一度、社内ネットワーク環境を「完全」に確認してください。

id:anesin

社内のPCを全ては確認できませんでしたが、

同一所属内(同ワークグループ内)での確認はできました。

ですが、サブネット及びDNS、ゲートウェイ、WINSの設定は

同一のものとなっておりました。

今までご投稿して頂いた方々に感謝いたします。

恐縮ですが、引き続きのご投稿をお待ちいたしております。

2004/11/24 23:02:48
id:mkun No.7

mkun回答回数72ベストアンサー獲得回数02004/11/24 23:04:15

ポイント300pt

1.ネットワークーへのアクセス権

を設定している、アカウントでお使いですか?

2.ネットワーククライアントのサービスが

何らかの理由でとまってませんか?

2.pingまたは、コンピューターの検索で

PC自身のipで検索してみてください。

とおらなければ、ネットワークアダプター

または、PCの問題です。

となりにPCがあったりするなら

ケーブルを入れ替えてみるのも

方法ですね、

現象が変わらなければPC自体の問題に

なります。

他のPCとIPアドレスのみ入れ替えれてみて

現象が移らなければipアドレス

の問題ではないということになります。

サブネットマスクは0.0.0.0にして、現象が

解消されなければ、サブネットマスクは原因ではありません。

デフォルトゲートウエイは同じサブネットののPCからの通信には不要ですから、

これは外していいと思います。

DNSも同様windowsのローカル接続

では、なくても動きますから、これも原因と

は思えません。

後はネットワークアダプターのドライバー

の確認、くらいですか

id:anesin

ご回答のほど、ありがとうございます。

○ネットワークへのアクセス権

 administratorで入っており、権限の変更は行っていないので

 多分大丈夫だとは思います。

○ネットワーククライアントサービス

 済みません。具体的に、サービス名などは

 お教え頂くことはできないでしょうか

 言われてみると、OSをインストールした当初から、

 システム起動毎に、何かのサービスの立ち上げに

 失敗しました、とエラーが返ってきていたのですが、

 クリーンインストールだったのでさして気に止めていません

 でした。そのあたりに原因があるのでしょうか。

○サブネットマスク

 

 0.0.0.0 に設定が出来ませんでした。

 コマンドラインからアプリケーションを起動して

 強制的に書き換えるものがあったような気もしました

 が、そういったものを使わないと

 書き換えはできないのでしょうか。

○デフォルトゲートウェイ、DNS

 空欄に変えてみましたが、変化はありませんでした。

 とりあえず、空欄のままにしておきます。

○ドライバーの確認。

 済みません、とりあえずは保留にさせて下さい。

 他の作業と並行して確認させて頂きます。

 PC自体に問題がありそうな

 感じがしてきたので、別のPCを見繕って

 試してみます。

 ですが、引き続きの情報をお待ちいたしておりますので

 よろしくお願い致します。

2004/11/24 23:34:02
id:snitch No.8

snitch回答回数516ベストアンサー獲得回数92004/11/25 01:40:21

ポイント50pt

http://www.microsoft.com/japan/

マイクロソフト - ホーム

二度目の回答となります、すいません。

6の回答と近いですが、L3スイッチ等でセグメントが分けられていないでしょうか?

また、該当のHUBのポートでVLANが切られているのではないでしょうか?

また、HUBのカスケードポートにLANケーブルを繋いでないでしょうか?

(HUBのLINKランプは点灯していますか?)

その同一所属内の端末は同じL2スイッチ内のLANなのでしょうか?

つなげたLANケーブルをたどって確認してみてください。

もしくは他の端末に繋がっているLANケーブルを繋がらない端末につなげて同一現象なのか切り分けて下さい。

(できれば、テストは繋がる端末と同一のIP設定にするのが切り分けとしては良いテスト方法です。)

また、pingはマシン名で行っていますか?それとも、IPアドレスで行っていますか?

できれば、IPアドレスで行ってください。

id:hmom No.9

hmom回答回数46ベストアンサー獲得回数02004/11/25 01:54:53

ポイント50pt

http://www.atmarkit.co.jp/fnetwork/netcom/ipconfig/ipconfig.html

ipconfig - Windowsのネットワーク設定を確認する

1. DOS窓からipconfigと打って見た結果でかなり切り分けが可能です。

2. HubやPCのNICのLEDを見るのも有効です。

Ethernetレベルでリンクが確立したかどうかが分かります。

 最近のルータでは1G,100Mは対応していても10M非対応のものがあります。10M専用のNICを使っていた場合はEthernetのリンクが確立しません。

id:kuippa No.10

くいっぱ回答回数1030ベストアンサー獲得回数132004/11/25 01:59:04

ポイント150pt

ん。まだ解決していないようなので追加します。

サーバーにユーザ登録を済ませてあって、

DNSやWINSの設定をしていたとあったのでドメイン管理しているネットワークかと思ったのですが…

よくわかっていないということは、もしかしてDHCPなのでしょうか??

そうではないというのであれば、そのマシンはドメインに産かしましたか?

まいこんぴゅーたあたりを右クリックして、システムのプロパティからネットワークIDのタグ→プロパティでそのコンピュータがどのドメインに参加しているかを確認してみてください。

id:anesin

重ねてのご回答、ありがとうございます。

3件分、分かっている範囲で返事をさせて頂きます。

○HUB、LED

 カスケードポートにLANケーブルを差してはおりません。

 また、HUBのLINKランプ及びNICのLEDも点灯しております。

○HUB

 同一所属課内の端末は、複数のL2スイッチにそれぞれ

 繋がってはおりますが、

 テストを行った端末は、同一L2スイッチ(スイッチングHUBの

 事ですよね?)に収まっております。

○テスト

 他の動作している端末の、LANケーブルを、

 動作しない端末に繋げてみましたが、変わりはありませんでした。

 また、動作している端末のI.Pアドレスを使用しております。

 (現在、動作していた元のPCは停止させてあります)

○PING方法

 I.Pアドレスの方法でしか行っておりませんでした。

○NIC

 古いPⅡのマシンなので、恐らくは10M専用の物だと

 思われます。ですがHUBも古いものですので

 10/100 両方対応していたと思ったのですが、

 調べておきます。

○DHCPか否か

 DHCPではありません。

 ドメインに参加させる事の定義がわからなくて申し訳

 ないのですが、サーバにユーザ登録を済ませてありますが、

 ネットワークの設定の際に、ワークグループに参加させている状態です。

○ipconfig

 以下のメッセージが返ってきます。

 

 「 Windows NT IP Configuration 」

 ちなみに、ipconfig /all と打つと

 上記文言の他、

 hostnameマシン名+ドメイン名

 node typeBroadCast

 IP Routing EnableNO

 Wins Proxy EnableNO

 Net Bios Resolution USES DNSNO

 と表示されます。

 

 ※マシン名の右にドメイン名が表示されている理由として、

  会社の数少ないWindows98マシンには、

  ネットワークの設定を確認するとドメイン名が登録されている

  のでそれを真似た為です。

  (でも、実際のところはドメイン参加させているのではなく、

   恐らくはワークグループ?に参加させているものだと、

   思っています)

   わかりにくくて済みません

○その他

 順次確認させて頂きます。

恐縮ですが、引き続きのご投稿をお待ちしております。

2004/11/25 03:05:37
id:mutsuju No.11

mutsuju回答回数551ベストアンサー獲得回数352004/11/25 10:18:05

ポイント50pt

destination net unreachable が出ると言うことはroutingに問題が発生しているはずです。

1)問題が発生しているPCにLANカードは何枚ありますか? 複数あるならとりあえず1枚にしてみて下さい

2)他の正常に動作するPCで、route print コマンドを発行し、ルーティングテーブルを参照して下さい。

3)問題が発生しているPCで、同様にルーティングテーブルを参照して下さい

4)デフォルトゲートウェイが空欄なら外にping飛ぶはずがないので、他のPCを参考に正しいゲートウェイアドレス、サブネットマスクを設定して下さい。

5)これで外部にping飛びますか?

#社内の他のPCにもping飛ばないということなので、LANカードが複数あり、かつmetricが同一になってるような気がします。

可能なら route print の結果を貼ればもっと詳しい人が出てきてくれると思いますが。

id:anesin

ご投稿、ありがとうございます。

route printの結果をUPします。

一応、公開しても良いかどうか迷ったところは

編集してあります。ご了承下さい。

正常端末

Interface List

0x1 ........................... MS TCP Loopback interface

0x1000003 …98 76 54 32 10 ab ...... Intel(R) ***/100 AA Network Connection

===========================================================================

===========================================================================

Active_Routes:

Network_Destination________Netmask__________Gateway_______Interface_______Metric

__________0.0.0.0________________0.0.0.0_____________12.34.55.99_______12.34.56.78_______1

________12.34.55.99__________255.255.0.0________12.34.56.78________12.34.56.78______1

______12.34.56.78_____255.255.255.255________127.0.0.1_________127.0.0.1________1

___12.255.255.255___255.255.255.255______12.34.56.78______12.34.56.78_______1

________127.0.0.0________255.0.0.0________________127.0.0.1_________127.0.0.1_______1

________987.0.0.0________987.0.0.0_____________12.34.56.78______12.34.56.78________1

__255.255.255.255__255.255.255.255_______12.34.56.78_____12.34.56.78_______1

Default_Gateway:_________12.34.55.99

===========================================================================

Persistent_Routes:

__None

○エラー端末

Interface List

0x1 ........................... MS TCP Loopback interface

===========================================================================

Active_Routes:

Network_Destination________Netmask__________Gateway_______Interface_______Metric

________127.0.0.0________255.0.0.0________________127.0.0.1_________127.0.0.1_______1

となっております。

○LANカード枚数 目視で1つでした。

 デバイスマネージャで確認しても1つでした。

○ゲートウェイ、サブネット

 設定しておきました。

○PINGテスト

 今のところ、PINGは内外両方飛ばない状態に

 なっております。

○PC自体の不具合検証

 問題のある端末に、Win98を

 クリーンインストールしてみましたが、正常に

 動作いたしました。

 

 route print の結果も、

 上記正常端末のものと同じでした。

度々恐縮ですが、

引き続きのご投稿をお待ちいたしております。

--------------------------

申し訳ありません、原因と、解決方法がわかりました。

http://support.jp.dell.com/jp/jp/mwfaq/faq.asp?faqno=100257

Intel NICのドライバをインストールする場合の注意事項 (WindowsNT4.0)

ドライバが対応していなかった模様です。

アダプタの通信テストは問題無かったので

見過ごしておりました、申し訳ありません。

対応するドライバをあてて対処したいと

思います。

対応の良くなかった部分があり

申し訳ありませんでした。

今後ともよろしくお願い致します。

2004/11/26 15:54:35
  • id:kuippa
    (;’ω’)ン 解決しましたか…?

    レスの中で、DHCPではないがドメインには参加させていないとのレスがちょっと気になっています。127.0.0.1じゃない自分のIPにはpingとびますか?
    結局ドライバの問題だったのでしょうかいな??

    さすがに二回の回答じゃフォローしきれないですね(^-^;
  • id:mkun
    自己フォロー

    ネットマスクの0.0.0.0
    セキュリティは
    自分でやってみてできなかったので驚きました、
    要するにネットマスク対称部分の、IPが一致してればOK
    なのですが、
    WIN98では原因の切り分けに有効だったんだすけどねえ
    ついでにネットマスクをづらしたまま使ってたら、SQLに接続できなくなりました。ネットマスクもセキュリティチェックに入ってるようですね。
    結果の詳細をいただけたのは大変ありがたいですね。
    正確で丁寧なレポートで私も勉強になりました。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません