家庭内ネットワークについて質問です。

ノートPC2台(2000(以下A)、XP(以下B))を接続していますが、2通り使っています。
(1)ワイヤレスLANでルータ経由接続
(2)IEEE1394でPC同士直接接続
(1)は問題なくつながるのですが、(2)が一方通行で、AからBを覗くことはできますがBからAが見られません。今まではつながっておりましたので、原因が不明です。もちろん、ファイアウォールは切って試しても同じです。

確認したところは、
・cmdでのipconfigでは双方に169.254.〜のipが設定されている。
・双方、IPは自動取得。NetBIOSoverTCP/IPも有効。
・IPにpingはそれぞれ、自身に対して打つと戻ってくる。そしてA→BはOK。B→Aはリクエストタイムアウト。
・AからBは見られる。両方とも共有設定はしてあり、AからBへのファイル送信も可。ということでIEEE1394のケーブルなどのトラブルは考えられない。
・直接IPを打てばBを参照できるが、AのマイネットワークにはBが存在しない。
「(1)で接続できてるからいいじゃないか」という答えはいりません。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2005/02/06 18:12:32
  • 終了:--

回答(6件)

id:nobukin80 No.1

nobukin80回答回数9ベストアンサー獲得回数02005/02/06 18:25:35

IEEE1394の障害ではないでしょうか?

A→Bはルータ経由で通信できているのではないかと思われます。

tracertをしてみるとどうでしょう?

id:notch

文字数制限でこれ以上長い質問できないの。文脈からわからないかな?1394のためにワイヤレスはもちろん切ってるし、もしルータがつながってればB→Aもつながるでしょ。だからIEEEのトラブルは考えられないってことなんだけど。

2005/02/06 18:41:17
id:quintia No.2

quintia回答回数562ベストアンサー獲得回数712005/02/06 19:14:43

サブネットマスクの部分が変更された様子はありませんか?

サブネットマスクによって区切られた上位部分に違いがあると、マイネットワークにはでてこないがIP直だとつながるという現象を見たことがあります。

差し支えなければ、両方のマシンでipconfig /all した結果をコメントに付けてもらえると後に続く回答者のヒントになるかもしれません。

id:notch

変更された様子?どこからわかるものなんでしょう?

2000のほうが

Ethernet adapter IEEE1394接続:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : Sony i.LINK(1394) Adapter

Physical Address. . . . . . . . . : **-**-**-**-**-**(伏せます)

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Autoconfiguration IP Address. . . : 169.254.100.45

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

DNS Servers . . . . . . . . . . . :

XPは

Other dpter 1394接続:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : 1394ネット アダプタ

Physical Address. . . . . . . . . : **-**-**-**-**-**(伏せます)

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Autoconfiguration IP Address. . . : 169.254.3.90

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

2005/02/06 19:21:45
id:kimudon No.3

kimudon回答回数1909ベストアンサー獲得回数1712005/02/06 19:57:25

ポイント10pt

http://www.vaio.sony.co.jp/Enjoy/Download/Smart/

ENJOY VAIO | お楽しみダウンロード | 「Smart Connect Ver.3.0」 無償アップグレード

Win2000のPCはSONYのVAIOでしょうか?

Smart Connectは Ver3.0になっているでしょうか。

id:notch

ええと、だから

>今まではつながっておりましたので、原因が不明です。

って書いてありますよね。質問ちゃんと読んで。

2005/02/06 20:19:12
id:unchidopon No.4

unchidopon回答回数57ベストアンサー獲得回数02005/02/06 20:10:48

http://www.vector.co.jp/

Vector: ソフトライブラリ&PCショップ - 国内最大級の フリーソフト ダウンロードサイト

WinXPなら簡単にネットワークができます。

id:notch

意味わかんねえよ。

そのURLはなんなの?どこに解決策があるの?

2000がつながらないって書いてんだけど。

2005/02/06 20:20:39
id:quintia No.5

quintia回答回数562ベストアンサー獲得回数712005/02/06 20:49:05

ポイント40pt

> サブネットマスクの部分が変更された様子

どちらかが変更されて、食い違った状態になっていませんか? と書けば良かったですね。すみませんでした。

さて、回答のURLを読むと、IEEE1394に対応するのは(正式には)XP,Meだけと書いてあります。”今までつながっていたのがたまたまだった”と考える方が自然かと思います。

(IEEEの添付ドライバが優秀だったとか……? 詳細は不明です。)

「ネットワークの設定に慣れていれば手動で割り当てるほうをお勧めしたいのですが」と書いてありますので、両方のIEEE1394のLANアダプタの設定で、IPアドレスを指定してみてはいかがでしょうか?

10.50.180.10 と 10.50.180.11

サブネットマスクは255.255.255.0 でいいかと思います。

(ワイヤレスLANルータが振るアドレスが10.50.180.* だったら 10.50.181. にでもしてください。)

マイコンピュータのプロパティでワークグループ名が一致しているかも確認して下さい。

XP,Meだけと書いてある記事は他にもあります。

id:notch

ええ、OSの正式サポートじゃないことは存じております。VAIOなんで1394は「iLink」って名前がついてて普通につながるんですよ、昔から。繋がるのはたまたまではなく、「仕様」です。ソニー側の正式サポートです。

基本的な設定は間違いないんですよ。ワークグループが違えばワイヤレスでも繋がらなくなるはずだし・・。今までIP自動でつながってたけど固定はまだ試してないです。根本的な解決ではないけど、やってみます。ありがとうございます。

2005/02/06 21:15:31
id:nobukin80 No.6

nobukin80回答回数9ベストアンサー獲得回数02005/02/06 20:54:24

ポイント40pt

http://www.system-talks.co.jp/support/item/LAN0001.htm

Windows XPでネットワークに接続できない

XPのブリッジ機能が自動で設定されてしまったということはないでしょうか。

最初はこういう構成と勘違いしましたすいません。

ipconfig/allの結果も正常にみえますし、純粋なネットワークの問題ではない気がします。

そうすると、あとはドライバの不具合が発症したとか。(kimudonさんも言及してますが。)

id:notch

ブリッジは大丈夫です。昔それで痛い目を見たので^^;

ああ、ドライバの不具合は確認してないですね・・・。

・・・圧縮してあるドライバファイルはCDに焼いてあったんで入れなおしたけど変わらないですね。う〜ん。OSのトラブルだったら手の打ちようがないなあ。

2005/02/06 23:06:44

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません