WEBサーバの中で 複数の dllhost.exe の内のひとつが OS起動後しばらくするとCPU使用率が100%になってしまい非常に困っています。



環境
OS: Windows2000Server(SP4)
IIS: 5.0

状況
1.ウィルスではない(トレンドマイクロのオンラインウイルスチェックを実施済み)
2.同一処理を行っている負荷分散用の別サーバでも発生している。したがって、現在は交互に再起動して運用中。
3.IISを再起動すると、とりあえず直る

困ってます。
対処方法をご存知の方、何卒ご教授いただけますようお願いします。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2005/06/27 22:15:26
  • 終了:--

回答(2件)

id:trueonline No.1

tsubasa回答回数19ベストアンサー獲得回数12005/06/28 01:12:00

ポイント30pt

http://support.microsoft.com/

Microsoft Help and Support

ご質問の再現条件が漠然としているようですので、差し当たっては調査のため「パフォーマンス モニタで監視してみる」ぐらいしか思いつきません。文書番号 253603 で検索してください。『[IIS] HOWTO: Internet Information Services での CPU 使用率が高い ”ハング” 状態のトラブルシューティング』が見つかります。

http://www.microsoft.com/japan/technet/prodtechnol/windows2000se...

Microsoft TechNet: Internet Information Services 5.0 ‐ 展開

Microsoft:『Windows 2000 Web アプリケーションのデバッグ』。「CPU 使用率が 100% に達する問題」セクションを参照してください。

お節介かも知れませんが:

よそ(OKWeb, 教えて!goo)でも質問されているようですが、一般的にマルチポストはあまり歓迎されませんよ。

現象の再現環境において、BAZZ さんが開発された DLL ファイルなり他社製品なりを使用されているのでしたら、そのことも書かなければ適切な回答が寄せられないと思います。

id:BAZZ

問題は dllhost.exe が CPU 100% となることで、冒頭の質問に書いてあります。

この質問は、よそ(goo)とは似ていますが、ちょっと条件が異なります。なので、マルチポストではありません。詳細な条件を提示することができない事情のため申し訳ございません。最後のリンクが気になって見ています。ご回答ありがとうございます。

2005/06/28 01:40:28
id:medical_blog No.2

medical_blog回答回数16ベストアンサー獲得回数02005/06/28 09:43:44

ポイント20pt

http://www.atmarkit.co.jp/fwin2k/win2ktips/384mdactool/mdactool....

@IT:Windows TIPS -- Tips:MDACのバージョン調査ツールを利用する

以前同様なことがうちでもありました。

その時はMDACのバージョンを上げたら治りました。

間違っていたらポイントいらないです。

id:BAZZ

ありがとうございます。

2005/06/28 10:09:46

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません