wamp5でphp4モードで使っています。

php_exif.dllを使いたいのですが、
php.iniで
extension=php_exif.dll
をコメント解除して、
apacheを再起動すると、
Unknown(): Unable to load dynamic library ’c:/wamp/php4/extensions/php_exif.dll’指定されたモジュールが見つかりません。
と出ます。
解決方法を教えてください。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2005/08/09 11:04:28
  • 終了:--

回答(2件)

id:ito-yu No.1

ito-yu回答回数323ベストアンサー獲得回数142005/08/09 11:12:02

ポイント25pt

ここから、通常のphp5zipパッケージを入手して解凍、extensionsフォルダ内のphp_exif.dllをc:/wamp/php4/extensions/の中にコピーしてみてはどうでしょうか?

id:kunitz

ありがとうございます!

php.iniにmb_string.dllのロードの後にphp_exif.dllを読み込んだら直ったぽいです。

そんなものなんでしょうか?

2005/08/09 11:16:29
id:ito-yu No.2

ito-yu回答回数323ベストアンサー獲得回数142005/08/09 11:21:49

ポイント25pt

http://jp2.php.net/manual/ja/install.windows.extensions.php

PHP: Windows 用 PHP 拡張モジュール - Manual

「php_mbstring.dll。php.ini で php_exif.dll は php_mbstring.dll の後で読み込まれる必要がある。 」とありました…

ところで、php4モードだと書いてあるのにphp5をおすすめしたさっきの回答、最低ですね。ごめんなさい。ポイントは結構です…

id:kunitz

ありがとうございます!

php_exif.dll は php_mbstring.dll の後で読み込まれる必要がある

2005/08/09 11:24:13

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません