Greasemonkeyがおもしろそうだなぁと思っているのですが使い方がわからないといいますか、反応してないようなのです。

3つくらいスクリプトを入れてみたのですが反応していないようです。
firefoxの右下にはサルのマークもでてますし、メニューの「ツール」にも「Install User Script」とか「Manage User Scripts」は表示されています。
スクリプトを登録したときに成功のダイアログもでます。
何が原因なのかネットで検索してもよくわかりません。
詳しい方、ぜひ教えていただけたらと思います。
ちなみにいれたスクリプトはmixi関係のです。
環境はmac10.3.9、Firefox1.0.6、Greasemonkey0.3.5です。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2005/08/18 21:53:11
  • 終了:--

回答(1件)

id:sanbo-n No.1

sanbo-n回答回数509ベストアンサー獲得回数12005/08/18 22:14:51

ポイント40pt

http://japan.cnet.com/news/sec/story/0,2000050480,20085595,00.ht...

Firefoxのアドオン「Greasemonkey」にセキュリティ上の欠陥 - CNET Japan

Greasemonkeyは前のバージョンにセキュリティの問題があって、現バージョンになりました。

しかし、そのセキュリティの問題を回避するために、URLの文中に


>バージョン0.3.5にはGreasemonkeyをHTMLよりも強力にするために考えられた「GM*」APIがなく、その結果これらのAPIに依存するスクリプトはバージョン0.3.5では動かなくなるとしている。ある開発者は「Greasemonkey 0.3.5はGreasemonkeyの去勢バージョンだ」と同ブログに書き込んでいる。


とあるように

前のバージョンよりも機能的に制限されている部分があるようです。

スクリプトのこととか詳しいことはわからないのですが、多分その辺が原因ではないかと思われます。(はてなグリースモンキーでも、グリースモンキーのバージョンアップによって使えなくなったものなどがありました。)

スクリプト作成者の方にスクリプトが現在のグリースモンキーのバージョンでも正常に動くのか、スクリプトの新バージョンが出ていないか、などをメールなどで直接聞かれてみることをオススメします。

id:poppycock

ちょっぴりそうなのかもと思ってました。

きっとgreasemonkeyが反応してないんじゃなくってスクリプトがバージョンに対応してないんですよね。

危険かなぁと思いながらもベータ版を入れてみたらできました。

ありがとうございました。

2005/08/18 22:47:07

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません