JSDKの1.5が入っています。で、1.4も入っています。今、java -versionって打つと、1.5がでてきます。

1.4でコンパイルしたいんですがどうすればいいですか?
windows2Kです。環境変数あたりをいじくりゃいいのかと思ったんですが、なんか使い古した環境なのでいっぱいありすぎてわかりませんでした(´・ω・`)
Java素人、略してジャバロウトの私にもわかるように簡単にお願いします。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2005/12/28 01:24:38
  • 終了:--

回答(1件)

id:hissssa No.1

hissssa回答回数423ベストアンサー獲得回数1272005/12/28 01:55:16

ポイント40pt

コマンドプロンプトから単にjavacでのコンパイルが出来ればいいだけなら、PATHだけ通せばいいですよ。コマンドプロンプトを開いて、以下のようにコマンドを打ちます。


>set PATH=(java1.4のホーム)¥bin;%PATH%


(java1.4のホーム)は、たとえば”c:¥j2sdk1.4.2_05”とかの、java1.4がインストールされてるディレクトリです。


あと、環境変数にCLASSPATHも指定されてるようなら、そっちのディレクトリもJava1.4用に設定します。特別なクラスを参照してなければ別に要りませんが。


これで、そのコマンドプロンプトでJava1.4のjavacが使えるようになります。後はjavacにソースを食わせればコンパイルできます。


> javac hogehoge.java


恒久的に設定したい場合は、システム環境変数を同様に設定しましょう。

id:kuippa

おー でけたでけた。

ありがとうございますーー

2005/12/28 02:28:07

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません