【Linux】mod_layout3.2をmakeすると下の日記のようにエラーになります。

http://d.hatena.ne.jp/yoshi5231/20060117
apacheのバージョンは1.3.34です。
原因分かる方よろしくお願いします。

こちらの環境はfedora4で現在apache2系でmod_layout4.2aを すでに使っています。
別ディレクトリにapache1.3があり
apache1.3と同じディレクトリにmod_layout3.2も置いてます。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/01/17 22:26:05
  • 終了:--

回答(1件)

id:Kumappus No.1

くまっぷす回答回数3784ベストアンサー獲得回数1852006/01/18 00:11:41

ポイント130pt

「こちらの環境はfedora4で現在apache2系でmod_layout4.2aを すでに使っています。」

とのことですが、日記を見ると

/usr/include/httpd/http_protocol.h

を参照して失敗しているようなので、apache2のインクルードファイルを見に行っているのが原因では?

手元にapacheのRPMがないのでわからないのですが、1.3.xのRPMでどこにインクルードファイルが入るか確認できますか?もし同じ/etc/httpd以下に展開されるのなら例えば1.3.x用のインクルードファイルを/usr/local/etc/httpdなどにおいて、mod_layout3.2のビルド時にオプション指定でインクルードパスを指定する必要があります。

id:yoshi5231

ありがとうございました

2006/01/19 07:04:11

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません