【Linux】apache1.3-develがフルインストールした時に入ってるディストリを教えてください。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/01/24 19:26:55
  • 終了:--

回答(3件)

id:Kumappus No.1

くまっぷす回答回数3784ベストアンサー獲得回数1852006/01/24 19:58:03

ポイント20pt

http://ftp.nara.wide.ad.jp/pub/Linux/Vine/Vine-2.5/i386/Vine/RPM...

Index of /pub/Linux/Vine/Vine-2.5/i386/Vine/RPMS

例えばVine 2.5などに入ってはいますけど…。(この少し上にISOがあるんで、拾ってきてCD-ROM焼けばVine2.5のインストーラができます)


そこからバイナリだけを持ってきても今のdistributionでは動かないですよ、たぶん。


また、

http://ftp.nara.wide.ad.jp/pub/Linux/Vine/Vine-2.5/i386/SRPMS.ma...

Index of /pub/Linux/Vine/Vine-2.5/i386/SRPMS.main/SRPMS

ここにapache-1.3.24-0vl1.src.rpmはあるので、1.3.24のソースのtar ballはこのRPMから取り出せると思います。


どうしても1.3系でやりたいのならApache1.3の全体を/usr/local以下にインストールして(各種optionで今のApache2と重ならないようにする)やるしかないでしょうね。


以下、私信モード。私はあまりApacheにもmod_layoutにも詳しくないんで、直接の回答は残念ながらできないと思いますが、前の質問で

apache2.xで白紙になるとか簡単な症状については記述がありましたけど特に前の質問まで見返す人は少ないと思うので

・環境(Linuxの何を使っているか,mod_layoutのバージョンなど)

・apache1.3ではうまくいっていたのか→移行はどのようにやったのか。

・細かい症状(どういう処理を行うと白紙になるのか~おそらくCGIの出力(動的生成)にフッタをつけたいのでしょうが、CGIで何をやっているとかそういう情報なども~や、常に白紙になるのか、など。できれば設定ファイルや出したいhtmlソースを差し障りのない範囲ではてなダイアリーにのっけるとか…)

・ログに何かメッセージが出ていないか→場合によってはメッセージを出させるようにlogのレベルを調整するとか

などを書かないと答えは得られにくいと思います。

僕もいちおうmod_layout 白紙などでググってみましたが同じ症状で悩んでいそうな人は引っかかってこなかったので…。

id:yoshi5231

環境とかはダイアリーに書いています。

http://d.hatena.ne.jp/yoshi5231/20060123

もう ディストリ変えてみようかな と思いまして

2006/01/25 08:15:44
id:graypenguin No.2

graypenguin回答回数17ベストアンサー獲得回数02006/01/24 22:24:40

ポイント20pt

http://www.a-yu.com/system/rpmc.html#qry

RPM コマンドの使い方

すいません。フルインストールの意味がよく分からないのですが、rpmパッケージでインストールしているのであれば、

rpm -ql apache-devel

で、表示されると思うのですが。違っていたらすいません。

id:yoshi5231

??ちょっと 違いますね

2006/01/25 08:16:46
id:kai10 No.3

kai10回答回数115ベストアンサー獲得回数32006/01/30 01:15:27

ポイント20pt

http://www.debian.org/CD/

Debian GNU/Linux on CDs

http://ftp.jaist.ac.jp/pub/Linux/Debian-CD/current/i386/iso-dvd

Index of /pub/Linux/Debian-CD/current/i386/iso-dvd

とりあえず、Debianには apache-1.3系、2.0系の両方があります。mod_layoutもパッケージとして準備されています。ですが、RPM系とはパッケージの分け方、ファイル構成、パッケージ管理コマンドが違ったりします。RPMは使わないので当然ですが。なので、慣れるまでちょっと面倒かもしれません。

また、apache-1.3系は、httpd-1.3.xx-x...rpm ではなく、apache-1.3.xx-x...rpm という名前になってたと思いますよ。

あと、何かお説教みたいになってしまって申し訳ないですが、ディストリビューションを変えて解決しようというのは、あまり良い選択肢とは言えない気がします。インストール時、ハードウェアの自動認識に失敗する、という場合にはありかもしれないですけど。というのは、結局どこかで同様の問題にはまるんじゃないかと思うからです…。

id:yoshi5231

わたしもそう思うのですが fedoraは どうしても駄目なようです…orz

2006/01/30 15:28:54

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません