【Linux】勉強もかねてFedora2でWebサーバーを構築しています。最新のものではないため、セキュリティーパッチなどをあてないといけないと思うのですが、参考になるサイト、もしくは直接ご存じの内容をご教授下さい。


現在、カスタムでインストールしapache,vsftpd,mysql,openssh,sendmailなど入れています。
基本的にWebサーバー以外の用途は考えていません。

また、今後こういった情報を入手していく上で役立つサイトもありましたら、お願いします。

ちなみに最新のFedora4を利用したかったのですが、なぜかインストール後いきなりカーネルパニックでどうにもなりませんでした。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/01/29 03:45:13
  • 終了:--

回答(3件)

id:tsukax No.1

tsukax回答回数15ベストアンサー獲得回数12006/01/29 04:48:27

ポイント30pt

http://fedoralegacy.org/updates/FC2/

The Fedora Legacy Project

英語のページですが、ここにFedora2のUpdateが載っています。

「fix security issues」などと書いてあるのがセキュリティパッチです。

下に行くほど、新しい情報が載っています。

ここには、Fedora1~4のアップデート情報ページへのリンクがあります。

これは、おまけです。


私がカーネルパニックなどに遭遇した場合、そのエラーメッセージをキーワードにして、googleで検索します。

このアドレスはその一例です。

「Kernel panic: VFS: Unable mount root fs」というエラーメッセージをそのままキーワードにしています。

日本語のページで解決できなかったときは、英語のページも見に行きます。

id:extrea

早速見てみます。

またカーネルパニックの件も一度ちゃんと調べてみたいと思います。ありがとうございます。

2006/01/29 13:15:54
id:inosisibeyan No.2

inosisibeyan回答回数211ベストアンサー獲得回数02006/01/29 08:09:41

ポイント20pt

http://pocketstudio.jp/linux/?Pocketstudio.jp%20Linux%20Wiki#con...

Pocketstudio.jp Linux Wiki - Pocketstudio.jp Linux Wiki

FC2からFC4へのアップデートは、ファイルシステムの異なるのが原因でカーネルパニックになります。

私の経験上、アップデートでなく、新規インストールでなければ入らなかったです。

具体的には、ext3から拡張されたLVMがFC4で採用されていてそのファイル設定が出来ていないのが原因です。以下FC5T2での例です。

# mount

/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)

...

FC2の設定などバックアップを取って、移行するのが良いかと思います。

id:extrea

なるほど!

まさにそのパターンでした。

アップグレードするつもりではないので

一度フォーマットしてから試してみます。

2006/01/29 15:10:37
id:save1981 No.3

save1981回答回数64ベストアンサー獲得回数02006/01/29 10:54:03

ポイント10pt

http://www.linux.or.jp/

$BF|K\$N(B Linux $B>pJs(B

LINUX全般バグ情報

http://apt.freshrpms.net/

[freshrpms.net] - Welcome to ayo

apt-getを利用してパッチが当てれます。

http://www.apache.jp/

JAPAN APACHE USERS GROUP

日本アパッチユーザーグループ

id:extrea

ありがとうございます。

2006/01/29 15:11:37

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません