fedora4 に ffmpeg をインストールしたいのですがうまく行きません。

lame-3.97はインストールしています。

ffmpeg-0.4.9-pre1のmake で

[root@localhost ffmpeg-0.4.9-pre1]# make
make -C libavcodec all
make[1]: Entering directory `/tmp/ffmpeg-0.4.9-pre1/libavcodec’
gcc -O3 -g -DHAVE_AV_CONFIG_H -I.. -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -c -o common.o common.c
In file included from avcodec.h:14,
from common.c:28:
common.h:67: error: 配列の型が不完全要素型を持っています
common.h:71: error: 配列の型が不完全要素型を持っています

とエラーが。。

対応方法として以下を試しましたが無駄でした。

[root@localhost ffmpeg-0.4.9-pre1]# export $CC=gcc32
-bash: export: `=gcc32’: not a valid identifier

どのように対処したらよいでしょうか?
よろしくお願いします。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/02/11 02:30:44
  • 終了:--

回答(2件)

id:tinyseraph No.1

ををた回答回数6ベストアンサー獲得回数02006/02/11 04:22:54

ポイント25pt

http://yanbaru.dyndns.org/linux/yum.html

Fedora core 5でyumを使う

お力になるか分かりませんが,yumからインストールされるのはどうでしょう?


#yum install ffmpeg

でインストールできるとおもうのですが。

id:wm107p

ありがとうございます。既に試しましたがダメでした。

2006/02/11 11:18:22
id:ttamo No.2

たも回答回数175ベストアンサー獲得回数292006/02/11 14:35:43

ポイント25pt

export CC=gcc32


つまり $ が不要です。

id:wm107p

すいません。これは記入ミスです。

はじめからexport CC=gcc32

でやってました。でもだめなのです。

2006/02/12 00:45:49

コメントはまだありません

この質問への反応(ブックマークコメント)

トラックバック

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません