格納されているMySQLのバージョンが4のXAMPP(for Windows)を探しています。

現在の最新バージョンはXAMPP for Windows 1.5.1で、MySQLのバージョンは5.0.18となっています。
使いたいPHPモジュールの中で使用しているSELECT文のJOIN部分が、MySQL4では問題なく通るのに対して、5ではエラーとなってしまうからです。
このようなSQLのSELECT文が膨大にあるため、PHP内のSQL文記述の変更ではなく、XAMPPの中のMySQLをバージョンダウンしようと考えまして、別途MySQLのバージョン4をダウンロードしてみましたが、どうも連携が上手くいかないようです。
サーバーがクラッシュして再構築中ですので、なるべく早く復活させるためにXAMPPを選択したのですが、新しすぎて困っています。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/02/16 15:53:53
  • 終了:--

回答(1件)

id:kimizu No.1

kimizu回答回数726ベストアンサー獲得回数212006/02/16 16:18:55

ポイント50pt

XAMPPがMySQL5を採用したのは、1.5からです。

ベータ版での採用日付は2005/10/26付近です。


MySQL4を使用した最終版のXAMPPは1.4.16となります。

参考URLからダウンロードしてみてください。

id:smileless

まさかこんなに早く回答をいただけるとは思いませんでした。

しかもバージョンの丁寧な説明まで・・・。

すばらしいです!

ありがとうございました!

これで目的は達したのですが、

できればMySQL以外は最新版を使いたいと考えています。

MySQLのみ差し替える方法がありましたらお願いします。

ということで引き続き質問を続けさせていただきます。

2006/02/16 16:23:55

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません