FC4の質問です。

BINDを最新版のrpmにソースrpmからバージョンアップをためしているのですが、
postgresqlもバージョンアップしなさい というように読めました。
ので、postgresqlもrpmでバージョンアップしようとしたらglibcもバージョンアップしてください。
と読めたので、
下記をしたのですが、エラーになります。
解決方法を教えてください。よろしくお願いします。
root@pisces[/usr/src/redhat/RPMS/i386]% ls
glibc-2.4-4.i386.rpm postgresql-devel-8.1.3-1.i386.rpm
root@pisces[/usr/src/redhat/RPMS/i386]% rpm -ivh glibc-2.4-4.i386.rpm
キルケ・ glibc-2.4-4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
・ィ・鬘シ: Failed dependencies:
glibc-common = 2.4-4 is needed by glibc-2.4-4.i386
gdb < 6.3.0.0-1.111 conflicts with glibc-2.4-4.i386
glibc > 2.3.5 conflicts with glibc-common-2.3.5-10.i386

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/03/30 13:48:44
  • 終了:2006/04/05 10:32:08

ベストアンサー

id:practicalscheme No.1

practicalscheme回答回数157ベストアンサー獲得回数422006/03/30 18:09:46

ポイント35pt

glibc-commonについてのメッセージは、glibcとglibc-commonのバージョンが同じでなければならないことを意味しています。またgdbについてのメッセージは、現在インストールされているgdbはglibc-2.4では走らないことを意味しています。結局、これら全てを同時にアップデートしなければなりません。

しかし、glibcは多くのプログラムで使われており、しかもそのうちの結構な数がglibcの特定のバージョンを要求するため、手で追ってゆくのはかなり大変です。

aptやyumのようなツールを使うと、rpmの依存関係を自動的に追って必要なパッケージをまとめてインストール/アップデートしてくれるので、まずはその手をお薦めします。

何らかの事情でaptやyumが利用できない場合、rpmに--forceオプションをつけて無理矢理入れてみるという手はあります (が、glibcでそれをやるのはかなりリスキーです)。

id:meichi

ありがとうございます。

rpmを極めようと挑戦していたのですが、やっぱり厳しいですね。

aptやyumはことばだけぐらいはしっていますが、これをつかうと公開されているソースの最新版にはアップデートするのは厳しいのではないでしょうか。u-n

2006/04/01 15:11:31

その他の回答(1件)

id:practicalscheme No.1

practicalscheme回答回数157ベストアンサー獲得回数422006/03/30 18:09:46ここでベストアンサー

ポイント35pt

glibc-commonについてのメッセージは、glibcとglibc-commonのバージョンが同じでなければならないことを意味しています。またgdbについてのメッセージは、現在インストールされているgdbはglibc-2.4では走らないことを意味しています。結局、これら全てを同時にアップデートしなければなりません。

しかし、glibcは多くのプログラムで使われており、しかもそのうちの結構な数がglibcの特定のバージョンを要求するため、手で追ってゆくのはかなり大変です。

aptやyumのようなツールを使うと、rpmの依存関係を自動的に追って必要なパッケージをまとめてインストール/アップデートしてくれるので、まずはその手をお薦めします。

何らかの事情でaptやyumが利用できない場合、rpmに--forceオプションをつけて無理矢理入れてみるという手はあります (が、glibcでそれをやるのはかなりリスキーです)。

id:meichi

ありがとうございます。

rpmを極めようと挑戦していたのですが、やっぱり厳しいですね。

aptやyumはことばだけぐらいはしっていますが、これをつかうと公開されているソースの最新版にはアップデートするのは厳しいのではないでしょうか。u-n

2006/04/01 15:11:31
id:practicalscheme No.2

practicalscheme回答回数157ベストアンサー獲得回数422006/04/01 16:22:23

ポイント35pt

apt/yumはrpmのラッパーにすぎないので、手動でのrpmインストールと併用することはできますよ。私も基本はyumで手に入る最新版にしていますが、リポジトリにまだ入っていないようなパッケージはrpmやsrpmを個別に入れます (ソースのtarballのみの場合もできるだけrpmにしてから入れるようにしています)。

同じライブラリの複数の異なるバージョンが必要な事態になると少々面倒ですが、このケースの場合はとりあえずglibcとそれに依存しているパッケージ群を一気にアップデートしてから取り掛かる方が楽だと思います。

(URLはダミーです)

http://q.hatena.ne.jp/1143694122

id:meichi

たびたびありがとうございます。

>ソースのtarballのみの場合もできるだけrpm

↑は、私もしっていますが、configureオプションを既存からバージョンアップするとなるととても難しいですよね。

今日はマシンが手元にないので、これからぼちばちですが やっていきます。

2006/04/02 17:39:18

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません