メモリ増設についてお聞きします。

マザーがShuttle MK20でCPUがAMDDURON1009MHZのボードにメモリを増設しようとしましたが、以前所持していたPC9821のメモリ32Mbしか動きません。
スロットは2つ、片方に128MBを装備済みに増設したいのです。
64MB以上のメモリを着けるとWINDOWSが起動せず、再起動をしたり、青いエラー画面のようなところで止まってしまいます。
WINはXPSP2ですが、どうすればいいか教えてください。
当方、まったくの初心者です。よろしくお願いします。
なお、メモリは購入店で動作確認済みで、BIOS上では認識しているようなのです。

回答の条件
  • URL必須
  • 1人5回まで
  • 登録:2006/05/02 07:32:24
  • 終了:2006/05/03 20:35:28

ベストアンサー

id:Kumappus No.3

くまっぷす回答回数3784ベストアンサー獲得回数1852006/05/02 09:26:48

ポイント25pt

http://eu.shuttle.com/archive/en/mk20_faq.htm#download

URLはダミー。マニュアルを見てみましたが(p45)、3.3V SDR SDRAM(PC100/133)であれば16〜512MBまでBIOSが自動認識して動くようですね。

1)128MBのメモリのみをDIMM 1またはDIMM 2に挿した状態ですか?サイズの違う2枚挿しだと動かないことがあります(マザーボードの仕様にはそうは書いてないようですが)。

2)CPU、メモリ、HDD(1台)、ディスプレイカードのみの最小構成で起動してみましたか?また合わせてそれらカード類の差し込みはきっちりしていますか?取り付け時にCPUファンがずれたりファン電源が抜けたりしてませんか?

3)電源容量に余裕はありますか?(これは確認が難しいか…例えば昔の100〜150Wクラスの小さな電源を使っていないか、ぐらいしか確認できませんね)

4)(仕様上は不要なはずですが)C-MOSクリアは試してみましたか?(マニュアルのp29の手順)

とにかくひとつずつ確かめていかないと原因を絞りこむのは難しいですが…。

最悪の場合は「マザーボードとメモリの相性問題」ということになってしまうかもしれません。

id:vcrystal

ありがとうございます。

相性ですかねえ?

サイズ違いはメモリ容量のことですか?

純粋に大きさのことなら高さは確かに違います。

現在は128と32を挿してます。

2006/05/02 11:28:58

その他の回答(5件)

id:ToMmY No.1

ToMmY回答回数656ベストアンサー獲得回数192006/05/02 07:41:13

ポイント20pt

BIOSのバージョンが古いためではないでしょうか?

バージョンアップしてみましたか?

http://www.plaza.across.or.jp/~kusunoki/bios2.htm

参考にしてください。

id:vcrystal

さっそくすみません。

すでに試みましたが…

それでだめでしたので、質問でした。

2006/05/02 08:25:26
id:ecchie No.2

ecchie回答回数63ベストアンサー獲得回数02006/05/02 09:19:36

ポイント20pt

http://www.komonet.ne.jp/~jisaku/chap5.htm

メモリのスロットは2つありますが、どちらに装着しても

変わらないでしょうか?きちんと奥まで刺さっていますか?

BIOSで認識していてもメモリの相性問題でダメな場合もあります。

購入店でもし保証があるようでしたら、交換してもらうのが

良いかもしれません。

念のためにメモリチェックをしてみるのも良いと思います。

以下解説サイトです。

http://shattered04.myftp.org/pc_38.html

id:vcrystal

入れ替えまくりましたから、単純に相性かも

すいません、相性のことならこれは回答不要です。

2006/05/02 11:30:29
id:Kumappus No.3

くまっぷす回答回数3784ベストアンサー獲得回数1852006/05/02 09:26:48ここでベストアンサー

ポイント25pt

http://eu.shuttle.com/archive/en/mk20_faq.htm#download

URLはダミー。マニュアルを見てみましたが(p45)、3.3V SDR SDRAM(PC100/133)であれば16〜512MBまでBIOSが自動認識して動くようですね。

1)128MBのメモリのみをDIMM 1またはDIMM 2に挿した状態ですか?サイズの違う2枚挿しだと動かないことがあります(マザーボードの仕様にはそうは書いてないようですが)。

2)CPU、メモリ、HDD(1台)、ディスプレイカードのみの最小構成で起動してみましたか?また合わせてそれらカード類の差し込みはきっちりしていますか?取り付け時にCPUファンがずれたりファン電源が抜けたりしてませんか?

3)電源容量に余裕はありますか?(これは確認が難しいか…例えば昔の100〜150Wクラスの小さな電源を使っていないか、ぐらいしか確認できませんね)

4)(仕様上は不要なはずですが)C-MOSクリアは試してみましたか?(マニュアルのp29の手順)

とにかくひとつずつ確かめていかないと原因を絞りこむのは難しいですが…。

最悪の場合は「マザーボードとメモリの相性問題」ということになってしまうかもしれません。

id:vcrystal

ありがとうございます。

相性ですかねえ?

サイズ違いはメモリ容量のことですか?

純粋に大きさのことなら高さは確かに違います。

現在は128と32を挿してます。

2006/05/02 11:28:58
id:seble No.4

seble回答回数4680ベストアンサー獲得回数6172006/05/02 10:47:13

ポイント10pt

http://global.shuttle.com/Product/MotherBoard/mbd_Spec.asp?M_id=...

これですよね?

メモリの規格はPC100か133です。

9821という事はDIMMであってもPC66のはずです。

メモリが遅すぎてシステムの速度に付いていけないのでしょう。

FSBを266にするのならPC133でなければ動かないと思います。

(性能の高いPC100なら可能性はあるけど、、、)

だいたい、古すぎ

id:vcrystal

古さはわかってます。

9821のもので問題ないのです。(128MBが元々で、追加にとりあえず9821の32MBのものを使ったのです。)

ちなみに両方PC100です

それを新しいものに変更がきかないので聞いているのです。

上記返信参照ください。

2006/05/02 11:35:42
id:seble No.5

seble回答回数4680ベストアンサー獲得回数6172006/05/02 16:25:54

ポイント17pt

ああ、やっと意味がわかりました。

であれば、逆にそのエラーを吐く新しいメモリに問題があるって事ですね。

なら、そのメモリの規格がまず問題だろうと思います。

ECC付(メモリチップの数が9ないし、18)とか

レジスタード(ちょっと小さいチップが余分に2個ほど付いている)

とかって事はありませんか?

古いメモリは外して新しいものだけではどうでしょう?

9821のがPC100というのも不思議な気がします。

http://alphonse.at.infoseek.co.jp/manual/memory.html

速度が混在でうまく認識しないのかも?

id:vcrystal

9821のものも後期だからでは?

組み合わせでは、全て試した結果ですが、元々にボード装備?(実は、ボード自体もらい物なんです)の128MBメモリはもちろんOK.

プラス、32MBが一番安定起動します。

今、それ以外に手元のものが3枚タイプ違いがあります。全てPC100で、32、64,128MBです。

その中でやはり32は動き、他はどう組んでもWIN起動時に再起動を繰り返したり、画面真っ暗だったりです。

お手上げですね。

1.IO-data pc100-222CL2 64M

2.メーカー不明 韓国製 32MB

 チップは18個裏表にある古いもの

3.ADTEC 128MR-PC100

裏表18個タイプの多分ECC付

です。

なぜ、32MBだけOKなのか?

この辺が、解決になる鍵みたいですが?

合計152MBでは、ウィンXPは重いですから、何とかしたいのですが…

2006/05/02 18:14:43
id:nontan2005 No.6

nontan2005回答回数492ベストアンサー獲得回数242006/05/03 00:57:49

ポイント18pt

http://www.barebones-pc.com/memory/Shuttle-MK20.html

ここを見る限り使えても良さそうな感じですね。

もしかして、マザーボードの設定がクロックアップ設定に

なっていませんか?

だとするとメモリータイミング厳しくなりますので。

id:vcrystal

ありがとうございます。

もう、これは相性がきついとしか思えませんね。

マザーの設定はどこをどうすればいいでしょうか?

そのへん、初心者なものでいじってないんですが。

2006/05/03 08:56:33
  • id:vcrystal
    有難うございました!
    どうも相性がめちゃくちゃハードのようで、5枚中1枚がやっとOKになるようです。
    とりあえず、中途半端な128+64の組み合わせで稼動してます。
    もっと試してみます。
    ポイントは、独断と偏見?ですが、均等になるようにしたつもりです。
    ご了承ください。
  • id:Kumappus
    直接正解になるかどうかわからなかったので2回目の回答にはしなかったのですが、マニュアル(私の回答のURLの下のほうにあります(MK20.ZIP))のp58にBIOSのメニューがあります。ここの右側の「LOAD FAIL-SAFE DEFAULTS」を選択すると(p86)、メモリタイミング他が最も緩やかな設定になります。
  • id:seble
    思うに、一番単純な答えは、うまく動かないメモリモジュールが壊れているのでは?という事です。
    他のPCで、できればmemtestでもかけてみれば一番かと、、、
    デュロン1GHzなので、メモリは100MHzなのだろうと思いますが、M/Bによっては勝手に133になってたりしますので、そこも確認。
    SDRAMで100MHzは楽勝ですが133は結構きついようです。
    120くらいまでは何とかクロックアップできますが、それ以上はやはり対応メモリでないと厳しいです。
    古いチップセットだと、9821のページにあるように、モジュール全体の容量だけでなく、個別のチップの容量に制限があったりしますが、このへんの世代で128Mbit程度は考えられません。
    (というか、対応しています)
    できれば、ECCのあるなしを混載させないほうが良いです。
    うまく動くか原因がはっきりしないと、こっちも気になります。
  • id:nontan2005
    確かにECCメモリーを使った場合、相性が厳しくなる場合は
    多いですね。
    クロックアップの設定ですが、いろいろ方法がありますので
    (極端なものだとCPUのピンを折ってしまうとか)
    実際見てみない事には何とも言えないのですが、
    マザーが対応(ジャンパー等の変更だけで実現出来るものなら)
    してるようであれば、動作クロック等を実際よりむしろ1段階程度
    遅くして正常に動くかどうか、まず確認した方が良いかもしれません。

    あと、古い容量の少ないメモリーは遅いと思いがちですが
    タイミングやリフレッシュレートの関係みたいで、こういった場合
    むしろ、容量の大きいDIMMより、認識しやすい事多いみたいです。
    私も過去9821の古いモデル(CPUはMMX166程度)のPC66 DIMMを
    互換機のMBに付けたらクロックアップ状態でも
    使えた事がありましたので。(本物のPC100-128あたりは駄目なのに)

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません