Tomcat-4.1.24上でWEBアプリ別に2種類のバージョンのStruts(1.2.9と1.1)を動かすことを

検討中なのですが問題なく共存できるかを心配しています。(以下に例を示します)
何か既知の不具合(クラスローダーがWEBアプリ間での同名クラスの違いを認識しないとか)はあるでしょうか?

例:
$TOMCAT_HOME/webapps/app1/WEB-INF/lib/struts-1.2.9.jar
$TOMCAT_HOME/webapps/app2/WEB-INF/lib/struts-1.1.jar

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/06/17 00:31:59
  • 終了:2006/06/24 00:35:03

回答(1件)

id:ksaito11 No.1

ksaito11回答回数44ベストアンサー獲得回数42006/06/17 01:06:31

ポイント60pt

Tomcatのクラスローダは、Webアプリ毎に別バージョンのStrutsを使うことができます。

下記を参照下さい。

http://tomcat.apache.org/tomcat-4.1-doc/class-loader-howto.html

http://www.atmarkit.co.jp/fjava/javatips/049jspservlet025.html

id:hiro_1979

大変参考になります。

ありがとうございました。

2006/06/17 13:36:51

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません