マインドマップのFreeMindのセットアップ方法

について解決方法をご存知の方教えて下さい。

現象:インストール後、起動すると「javaのバージョンが1.4より古い」という内容のメッセージが出て起動しません。

前提:
Java 1.5 , 1.4.2 両方インストールしてみました。
   
推測:Java1.4.0をダウンロードできるサイト
   Java 1.4.2 以上でも動作させる方法
   のいづれかがわかれば動くのではと
   思っています。宜しくお願いします。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/06/28 13:21:21
  • 終了:2006/07/05 13:25:03

回答(4件)

id:hinetk No.1

hinetk回答回数516ベストアンサー獲得回数362006/06/28 13:48:32

ポイント23pt

http://java.sun.com/products/archive/j2se/1.4.0_04/

こちらからダウンロードできるかと思います

id:yoshi12

見てみます

2006/06/28 19:37:29
id:hive7134 No.2

hive7134回答回数167ベストアンサー獲得回数162006/06/28 13:53:38

ポイント23pt

もし古いバージョンのJavaがインストールされているならば、アンインストールしてみてはいかがでしょうか?

それでもダメでしたら、

インストール先(C:\Program Files\FreeMind かな?)にあるFreemind.batというファイルを

右クリック→[編集]で開き、

二行目の先頭

java -cp lib\freemind.jar;l…

となっている部分を新しくインストールしたJavaのフルパスに修正してみると実行できるかもしれません。

例)

"C:\Program Files\Java\j2re1.4.2_03\bin\java" -cp lib\freemind.jar;l…

http://www.google.com

id:yoshi12

ありがとうございました。難しそうですね

2006/06/28 19:36:10
id:F57PB No.3

F57PB回答回数86ベストアンサー獲得回数02006/06/28 17:52:33

ポイント22pt

http://www.google.co.jp/(ダミーです)

まずは、カレントのJavaVMのバージョンを調べてみてはどうでしょうか?

コマンドラインから、java -version とするとバージョンが表示されます。

それが1.4.x以上かどうかを確認してみましょう。

もし、1.4.x以上でなければ、予期せずJavaVMがインストールされて、

それがカレントになっている場合があります。

(よくあるのが、Oracleをインストールすると古いJavaVMも一緒にインストールされてしまう)

その場合は、環境変数PATHを確認して、余計なjava.exeへのパスが通っていないかを確認し、必要であれば環境変数を書き換えます。

例えば、環境変数PATHが

c:/java1.3/bin;c:/java1.4/bin

のようになっている場合(あくまで例です)、java1.3のJavaVMが優先されてしまっていますので、順番を入れ替えて

c:/java1.4/bin;c:/java1.3/bin

のようにすれば、java1.4のJavaVMが優先されるはずです。

id:yoshi12

ありがとうございました。

2006/06/28 19:36:50
id:hive7134 No.4

hive7134回答回数167ベストアンサー獲得回数162006/06/30 13:47:42

ポイント22pt

あ、補足ですが、

「1.4より古い」というエラーは、

1.4.0以降なら出ないはずです。

なので、1.4.2以上や、1.5でも本来は動くはずです。

動かない原因は、

「1.4.0以前のバージョンのJavaが先に検出されてしまったから」

だと思います。

そこで、まずは古いバージョンがインストールされていればアンインストールしてはどうか?と提案いたしました。。

以下は参考までに。

先に検出されてしまう原因は、「環境変数の設定」にあると思われますので、環境変数をいじれば古いJavaを削除せずにすませることも可能です。

やり方は、WindowsXPの場合、

[コントロールパネル]→[パフォーマンスとメンテナンス]→[システム]→[詳細設定]タブ→[環境変数]ボタン

と進み、ユーザー環境変数とシステム環境変数の中に「Path」がないか探します。

Pathをクリックし、「編集」ボタンを押して、F57PBさんの回答にあるように、Pathの中身の順序を入れ替え、OKボタンを押せば完了です。

http://www.google.com

id:yoshi12

わかりやすかったです。ありがとうございます

2006/06/30 15:11:43

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません