ホームページ作成初心者です。ホームページビルダーを使ってます・

今日、ページ内リンクを作ってみました。が、プレビュー画面ではうまくリンク先に行くのですが、いざアップしブラウザで行うと、リンク先に矢印を持ってゆくと矢印が指に変わるのですが、まったく反応しません。ページの横にあるナビボタンは大丈夫なのですが、ページ上段のナビボタンもすべて反応しなくなってしまいました。他のページは問題ありません。
どうしたら直りますか?

回答の条件
  • 1人2回まで
  • 登録:2006/07/02 02:45:35
  • 終了:2006/07/02 12:17:21

回答(6件)

id:kimizu No.1

kimizu回答回数726ベストアンサー獲得回数212006/07/02 07:05:17

ポイント20pt

実際のページが見れるリンクでも貼り付けてもらえれば、

対処方法がアドバイスできると思うのですが。。。


ページ内リンクが失敗する状況としては、

 ・パソコン上のファイルへのリンクになっている。

 ・ページの縦方向が短いため、既にリンク先と同じ画面。

などでしょうか。

出来れば、実際のURLをお教えください。

id:kamekichiann

kimizu 様

早々にご回答ありがとうございます。URLは下記のところです。この中のページ内リンクは"CAR'S DIMENTION"のところです。あと、上のナビボタンが反応しなくなっています。

分かったらお願いします。

http://www.tradefullhouse.com/ocean%20freight.html

2006/07/02 11:15:58
id:ToMmY No.2

ToMmY回答回数656ベストアンサー獲得回数192006/07/02 09:17:34

ポイント20pt

ただリンクが切れているんじゃないでしょうか?またはjavascriptが無効になっているか。

検証方法は、ローカルで(upしないで)htmlを見て、リンクをクリックしてみる。つながれば、関連ファイルをupしていないか、フォルダ構造が違うなどになります。

またはブラウザのjavascriptが無効、javascriptにエラーがあって、それを検知してとまってしまうなどがあります。javascriptの設定を見直してください。(ブラウザの)

ファイル、又はソースがあると分かりやすいのですが・・

id:kamekichiann

ToMmy様

早々にご回答ありがとうございます。URLは下記のところです。この中のページ内リンクは"CAR'S DIMENTION"のところです。あと、上のナビボタンが反応しなくなっています。

分かったらお願いします。

http://www.tradefullhouse.com/ocean%20freight.html

2006/07/02 11:17:43
id:mitou73 No.3

mitou73回答回数67ベストアンサー獲得回数52006/07/02 11:23:44

ポイント20pt

"%20"ってことは、ファイル名に半角スペースが入ってますね。

他にも問題あるかもしれませんが、まずは半角スペースを取り除きましょう。

"_"などに置き換えればOKです。

(参考URL)

http://msugai.fc2web.com/web/tips/types.html

id:kamekichiann

ありがとうございます。

2006/07/02 12:15:46
id:mitou73 No.4

mitou73回答回数67ベストアンサー獲得回数52006/07/02 11:30:34

ポイント20pt

あ、あと、<base>タグがローカルになってますよ。

 ↓

<BASE href="file:///C:/Documents and Settings/Fullhouse/My Documents/My Webs/tradefullhouse/ocean freight.html">

id:kamekichiann

mitou73様

ありがとうございます。

ご指摘のタグを取り除いたらうまく行きました。

2006/07/02 12:13:16
id:aase No.5

aase回答回数132ベストアンサー獲得回数52006/07/02 11:37:20

ポイント20pt

拝見したところ<body>部分のタグ自体には問題がないようです。恐らく


<BASE href="file:///C:/Documents and Settings/Fullhouse/My Documents/My Webs/tradefullhouse/ocean freight.html">


という上から四行目のタグ、こいつが曲者なのではないかと。

リンクにマウスをのせるとステータスバーに「file:///C:/Documents...」と出ます。つまりリンク先が、閲覧者のパソコンのフォルダ内部に設定されてしまっているわけです。他の部分にはそういった記述は見あたらないし、絶対パス(http://…)でアドレスの設定されている3つのメールフォームには問題無く飛べますので、恐らくこのタグを除けば解決すると思います。

ビルダーで作るとこういう事はままあります。<meta>タグというのは、検索ロボットの回避等一定の用途を除いてはあってもなくてもいいもの(場合によってはあるがためにこういった障害をひきおこすもの)なので、削ってしまっても構わないと思います。

id:kamekichiann

aase様

ありがとうございます。

ご指摘のタグを取り除いたらうまく行きました。

2006/07/02 12:14:30

質問者が未読の回答一覧

 回答者回答受取ベストアンサー回答時間
1 sudayosiaki 204 166 6 2006-07-02 11:57:13

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません