Mac OS XでFirefoxを使っています。ブラウジングする際に極力マウスや矢印キーを使いたくありません。firstfieldというextensionは私にとって欠くことの出来ないものだったのですが、Firefox1.5では動作せず、動作する版を提供してくださっていたサイトも先日からアクセスできないようになってしまい大変困っています。

そこで
- firstfieldの代わりになるようなextension
- firstfieldを1.5でも動作するように変更する方法
を教えていただけないでしょうか。
またキーボード派が導入すべきextensionがあればそれも教えていただきたいです。

回答の条件
  • 1人2回まで
  • 登録:2006/07/08 15:08:29
  • 終了:2006/07/08 22:05:21

ベストアンサー

id:ToMmY No.1

ToMmY回答回数656ベストアンサー獲得回数192006/07/08 17:00:13

ポイント60pt

自分で改変してください。

xpiは実はzipファイルです。ファイル名を変えて解凍してみるとフォルダとinstall.rdfというファイルが出てくるはずです。

install.rdfをメモ帳で読むとこのような箇所があるはずです。

<em:minVersion>バージョン</em:minVersion>

<em:maxVersion>バージョン</em:maxVersion>

これが原因で、maxVersionをお使いのバージョンより新しいもの(1.5だったら1.5+とかくか、1.7などと書く)に書き換えてください。そうするとfirefoxをだましてインストールできます。

しかし、もし本当に動作しないのでしたら、firefoxが強制終了されたりするかもしれません。その場合はすべてを自分で書き換えるかあきらめるかしてください。

終わったらフォルダの中身(install.rdfと解凍で出来たフォルダ)を適当な名前のzipに圧縮し、xpiに書き換えて、インストールしましょう。

id:tarokimura

インストールできました。こんなに簡単にできるとは...

また快適なブラウジングを楽しめそうです。

ありがとうございました。

2006/07/08 18:03:54

その他の回答(1件)

id:ToMmY No.1

ToMmY回答回数656ベストアンサー獲得回数192006/07/08 17:00:13ここでベストアンサー

ポイント60pt

自分で改変してください。

xpiは実はzipファイルです。ファイル名を変えて解凍してみるとフォルダとinstall.rdfというファイルが出てくるはずです。

install.rdfをメモ帳で読むとこのような箇所があるはずです。

<em:minVersion>バージョン</em:minVersion>

<em:maxVersion>バージョン</em:maxVersion>

これが原因で、maxVersionをお使いのバージョンより新しいもの(1.5だったら1.5+とかくか、1.7などと書く)に書き換えてください。そうするとfirefoxをだましてインストールできます。

しかし、もし本当に動作しないのでしたら、firefoxが強制終了されたりするかもしれません。その場合はすべてを自分で書き換えるかあきらめるかしてください。

終わったらフォルダの中身(install.rdfと解凍で出来たフォルダ)を適当な名前のzipに圧縮し、xpiに書き換えて、インストールしましょう。

id:tarokimura

インストールできました。こんなに簡単にできるとは...

また快適なブラウジングを楽しめそうです。

ありがとうございました。

2006/07/08 18:03:54
id:apple-eater No.2

apple-eater回答回数420ベストアンサー獲得回数82006/07/08 18:52:04

ポイント10pt

そんなアナタにOperaを勧めたいワタシ。

Opera Help: Keyboard Shortcuts

9になってFirefoxに操作が似てきました。

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません