Windowsの起動プロセスに詳しい方にお聞きします。

オーディオカードを導入したところ、WindowsXPが起動途中で止まるようになってしまいました。
Windowsロゴが出ているところで、プログレスバーがカクッと動きが悪くなり、直後に止まってしまってそれから動きません。セーフモードで起動後、オーディオカードのドライバを削除すると正常に起動しますので、このオーディオカードが原因というのは分かります。
相性の問題かとも思うのですが、なんとか使いたいのです。何か方法はありますでしょうか?時たまうまく起動出来る時もあり、音もちゃんと鳴りますので、Windowsロゴが出ているときに止まらない方法、たとえばデバイスドライバの読み込む順番を変更するなど、ご存知の方居られましたら回答お願いいたします。
ドライバインストール直後は正常に立ち上がります。すぐに再起動しても、正常です。だが、しばらく電源を切って立ち上げると途中で止まってしまうようです。

スペックは以下のとおり

オーディオカード: E-mu 0404 (Creative)
CPU: Pentium4 2.8GHz HT
メモリ: 1GB
マザーボード: Aopen AX4C MaxⅡ
チップセット: Intel875P Canterwood

回答の条件
  • 1人2回まで
  • 登録:2006/07/16 00:06:18
  • 終了:2006/07/16 22:29:52

ベストアンサー

id:pasosavi No.4

pasosavi回答回数761ベストアンサー獲得回数282006/07/16 17:11:50

ポイント37pt

切り分けの第2投…

それはマザボがだめぼでなければ

サウンドボードがだめぼなのかもです…

(ドライバ云々/システム云々よりそちらが怪しいような


現実難しいかもしれませんが

別筐体にこのサウンドボードを挿してみると吉かと :-)

(似ているマザーであればあるほど吉


・正常に起動/運用/持続性がある→マザボがだめぼ

・だめぼ→サウンドボードがだめぼ

http://jp.creative.com/products/product.asp?category=237&sub...


#最初正常に起動/運用しているかに見えて

 コンデンサーあたりが時限爆弾劣化…よくある話かも

id:yoshidako

ありがとうございます。

別の筐体を用意するのは難しいですね。会社のに入れるわけにいかないし・・・。

確かにオーディオカード自体が駄目なのかもしれませんね。

動いたり動かなかったりだったので、どうにか安定して動かす方法は無いかと考えていたのですが。

保証期間も残っていますので、サポートに送ろうと思います。

ありがとうございました。

これで終了とさせていただきます。

他に何かアドバイスがありましたら、掲示板にお願いします。

ナイスな書き込みがあれば、ポイントをお送りします。

2006/07/16 22:26:29

その他の回答(3件)

id:kurukuru-neko No.1

kurukuru-neko回答回数1844ベストアンサー獲得回数1552006/07/16 01:43:09

ポイント30pt

HyperThreadingが怪しいです。

C:\boot.ini

ファイルの

[operating systems]の

multi(0).....

の記述があると思います。

multiの行を一行コピーして

Microsoft Windows XP Home Editionで

あればコピーした行の

Microsoft Windows XP Home Edition(HT OFF)

のように違う文字列にします。

[operating systems]の

multi(0).....

multi(0).....

修正が完了したら

msconfigコマンドを実行して

変更されたboot.iniの内容を確認してください。

正しく修正されてたら

追加した行を選択して詳細オプションの

/NUMPROCの指定で1を指定してください。

(HTに関係なくCPU数を1とする指定)

タイムアウト時間が0の場合30秒程度に

変更。

以上の変更をした状態で再起動すると

起動時に起動方法を選択する

メニューが表示されます。

追加した行で起動できたら、ドライバーが

ハイパースレッドに対応していない事が

原因と思います。

id:yoshidako

回答ありがとうございます。

ハイパースレッディングをBIOSで無効にしてみても、同じ(立ち上がったり立ち上がらなかったり)だったのですが、教えていただいた boot.ini を変更する方法でやってみました。

すぐは正常に立ち上がりました。プログレスバーは、カクッと止まりかけたようになりましたが、なんとか最後まで起動して、音も鳴りました。

そこから、再起動してみても、正常に起動しました。

しばらく電源OFFの後、起動(HT OFFで)してみると以前と同じようにWindowsロゴの途中でハングしてしまいました。

上手くいくときといかないときの違いが、イマイチはっきり分からないので、やっかいです。

オーディオカードのメーカーでは

Hyper-Threadingを有効にした環境での動作確認はできており、問題はありません。

http://jp.creative.com/support/faqs/jp/creativepro/digitalau...

となっていました。

2006/07/16 13:46:52
id:pasosavi No.2

pasosavi回答回数761ベストアンサー獲得回数282006/07/16 01:45:13

ポイント23pt

http://aopen.jp/products/mb/ax4cmax2.html

切り分けの第一投…

もしかしてオンボードのサウンドをBIOSで切っていないとか

環境により、

・オンボードを切らないと両方鳴る

・オンボードを切らないと両方鳴らない

ということが以前自作であったのですが

(最近のマザボはどうでしょう…

id:yoshidako

回答ありがとうございます。

BIOSでは、オンボードサウンド、S-ATA RAID、IEEE1394、は使わないので切ってあります。

あと、BIOSのバージョンは最新に、CMOSクリアも試しました。

PCIスロットを差し替えたりもしてみています。

実は最初に購入したときに、同じような症状に悩まされたのですが、突然普通に立ち上がるようになったのです。

しばらくそれで使えていたのですが、今回また最初のように立ち上がらなくなってしまった為、OSクリーンインストールの後、OSのパッチを最新にして、オーディオカードをインストールしてみたものの、上手くいかず質問してみています。

メーカーサポートにも連絡してみましたが、有効な手立てが見つかっていません。

最初に書けば良かったですね。すみません。質問の文字数制限(500文字)で、書ききれなかったのでした。

2006/07/16 14:11:35
id:kurukuru-neko No.3

kurukuru-neko回答回数1844ベストアンサー獲得回数1552006/07/16 12:24:21

ポイント10pt

マルチプロセッサ環境での動作も保証いた

しかねます。

となっていますね。

HyperThreadingも基本的にマルチプロセッサ

なのでNGです。

http://jp.creative.com/products/product.asp?category=237&sub...

id:yoshidako

回答ありがとうございます。

マルチプロセッサは動作しないとなっていますが、Hyper-Threadingには対応しているようです。

http://jp.creative.com/support/faqs/jp/creativepro/digitalau...

2006/07/16 14:25:06
id:pasosavi No.4

pasosavi回答回数761ベストアンサー獲得回数282006/07/16 17:11:50ここでベストアンサー

ポイント37pt

切り分けの第2投…

それはマザボがだめぼでなければ

サウンドボードがだめぼなのかもです…

(ドライバ云々/システム云々よりそちらが怪しいような


現実難しいかもしれませんが

別筐体にこのサウンドボードを挿してみると吉かと :-)

(似ているマザーであればあるほど吉


・正常に起動/運用/持続性がある→マザボがだめぼ

・だめぼ→サウンドボードがだめぼ

http://jp.creative.com/products/product.asp?category=237&sub...


#最初正常に起動/運用しているかに見えて

 コンデンサーあたりが時限爆弾劣化…よくある話かも

id:yoshidako

ありがとうございます。

別の筐体を用意するのは難しいですね。会社のに入れるわけにいかないし・・・。

確かにオーディオカード自体が駄目なのかもしれませんね。

動いたり動かなかったりだったので、どうにか安定して動かす方法は無いかと考えていたのですが。

保証期間も残っていますので、サポートに送ろうと思います。

ありがとうございました。

これで終了とさせていただきます。

他に何かアドバイスがありましたら、掲示板にお願いします。

ナイスな書き込みがあれば、ポイントをお送りします。

2006/07/16 22:26:29
  • id:kurukuru-neko
    HyperThread OKでMP NGと言う事
    はありません。

    並列性能の違いによる違いなのでソフト的には、確実に
    ソフトの不具合の疑いた高い。 この現象は組み込まれている
    ドライバー等の順序やタイミングにより発生するので
    起こったり起こらなかったりします。

    大手の100万本単位で出荷されているソフトウェアで
    さえ同じようにHyperThreadOK 、MP NG
    と言っているでも同じよう症状が発生する事があります。

    SCSIドライバーでもそんな製品がありますから。


    EMU 最新ドライバー/FIRMは適用していますか?
    http://www.emu.com/support/files/download2.asp?Centric=764&Platform=1

  • id:pasosavi
    確かにkurukuru-neko氏のコメントは当を得ていますね…

    全然別件ではありますが、
    Windows2000のサービスパックの適用と
    NICドライバのインストールの順番が違うだけで
    転送速度に大幅な違いが生じる
    という以前の有名な話を思い出しました…

    もしかしたらクリーンインストール直後の一番最初に
    こちらのボードを導入すると吉なのかもです :-)
    この機会にシステムの軽量化も兼ねてトライとか

    #でも本当にサウンドボードがだめぼだったらやっぱりだめぼですが
     (あるいはマザボがだめぼというよりはオンボードデバイスドライバとの整合性
  • id:kurukuru-neko
    --- 本来ありえませんが 勘 ----

    そのボードを使ったことがないのですが
    もしかしたらPCI IRQルーティングに
    何らかの問題があるのかもしれません。
    おばかさんで占有がないと動かないとか?
    そんなこと普通はないと思ったのです。
    そんなことあるみたいです。
     http://jp.creative.com/corporate/pressroom/releases/welcome.asp?pid=12257

    使っていない、プリンター・シリアルの
    IRQを可能な限りあけて

    BIOSでPCIボードに固定IRQを
    割り当てみるのも手かもしれません。

    デバイスマネージャのIRQリソース
    割り当ては確認できます。

  • id:pasosavi
    #IRQ指定しないとだめぼなボード?まさか…でもそうかも

    一方で簡単で究極な方法を思いつきました。:-)
    同一筺体における同一OSのデュアルブートです。
    (別パーティションの容量が4GBぐらい必要

    ・別パーテにOS新規インストール
    ・件のサウンドボード導入
    ・安定すれば環境(他のデバイス等)のせい
     やはり同じならサウンドボードのせい
  • id:yoshidako
    色々調べていただいてありがとうございます。
    早々と終了しないほうが良かったですね。
    昨日、書き込んでいただいたことを色々試して一日経って
    しまいました。

    IRQがかなり怪しそうです。
    IRQの競合が起こっていなければいいと思い込んでいたのですが、
    共有も駄目なのですね。

    ドライバ導入直後は共有は無いのですが、
    しばらく電源OFFにした後、ONにしてみると立ち上がらず、
    その後セーフモードで立ち上げてみると、見事にIRQが
    SMBusコントローラー というのと
    共有していることになっている。

    で、シリアルポートとパラレルポートを
    BIOSで不使用にしてみました。
    最初は空いたIRQ番号にSMBusコントローラが入ってくれて、
    共有は解消されているのですが、
    しばらく電源OFFにしたあとやってみるとまた駄目。
    セーフモードで立ち上げると、SMBusコントローラーが追っかけてきている。
    (来るなぁぁぁぁ!)

    セーフモードではオーディオデバイスは動いていないので、
    立ち上がらないときとは又別かもしれませんが。
    確認する手段がないです。

    >BIOSでPCIボードに固定IRQを
    >割り当てみるのも手かもしれません。

    これをやってみようと思ったのですが、
    BIOSの設定では、Plug&Play に対応していないデバイスを
    割り当てるためにIRQを空けることは出来ますが、
    オーディオカード自体が Plug&Play で他の番号へいって
    しまって、意味がなかったです。

    Aopen: Award BIOS 設定マニュアル
    http://aopen.jp/tech/faq/mb/bios/intelich5/index.html

    それとも他にやりかたがあるのでしょうか?
    調べてみると、WinXPではIRQの手動割り当ては出来ない
    という記述もあるのですが。

    Microsoft: Windows XP の IRQ 共有について
    http://support.microsoft.com/default.aspx?scid=kb%3Bja%3B314068

    ACPIを切ってIRQを弄るという方法もありそうなので、
    デバイスマネージャの"コンピュータ"の
    "ACPIプロセッサPC"を"標準PC"に入れ替えるということを
    やりかけてみたのですが、
    マウスが動かなくなったり、グラフィックがVGAになったりと
    ちょっと対処しきれない感じを受けたので戻しました。

    ボードを全部のPCIスロットに挿し直してみたら、
    なんとかSMBusとはIRQ共有しない場所が見つかりました。
    USBコントローラーとは共有することになってしまったのですが。
    で、昨日は何度か電源OFFしてしばらくおいたあとでも、調子よく
    動いていたのですが、
    今朝立ち上げてみると、また途中でハング。
    そのまま会社に出てきて今に至ります。

    >もしかしたらクリーンインストール直後の一番最初に
    こちらのボードを導入すると吉なのかもです :-)

    ほとんど、これに近い状態なのです。
    原因を元から断つ!と決断して、データバックアップ。
    HDフォーマットののち
    WindowsXP クリーンインストールして、
    チップセットのドライバ導入。
    ウィルス対策ソフトインストールと
    XPのSP2とパッチの適用。
    この状態でやろうとしたのですが、
    もしかして、もっと前(チップセットドライバ導入直後とか)
    という意味ですか?


    >同一筺体における同一OSのデュアルブートです。

    実はこれも、今回調子が悪くなる前にやっていました。
    一番最初の導入時も調子が悪かったのと、
    どちらにしても音楽制作する環境は余計なソフトは無いほうが
    いい(最高のパフォーマンスを引き出すため)ので、
    デュアルブートしていました。
    そのときは両方とも動いていたんですけどね。


    故障か、相性か絞りきれないので
    困ってしまうのですが、
    やはり修理に出してみるしか無いかなーと
    思い始めているところです。

  • id:kurukuru-neko
    x86 ベースのシステムの場合、このスイッチにより、オペレーティング システムは、
    PCI (Peripheral Connect Interface)
    デバイスに対するハードウェア入力リソース、
    ハードウェア出力リソース、および割り込み
    要求リソースの動的な割り当てを中止します。
    このスイッチを使用すると、デバイスは BIOS
    により構成されます。

    /pcilock
    http://support.microsoft.com/default.aspx?scid=kb;ja;833721
  • id:pasosavi
    #kurukuru-neko氏には脱帽…
     Qシステムで苦しんだ歴戦の猛者のお一人とお見受けしました…
     これからはにゃんこ先生と呼ばせていただきたく(大ちゃん談)

    一方でこのサウンドボード購入者のうち
    このマザボで皆が皆IRQを手動設定
    ということであれば商品として成り立たないような気も
    (少なくともすぐに生産停止/改良バージョンリリース
    であれば実は不良ロット?まさか…でもあり得るかもです…

    #実もふたもないかもしれませんが、
     これはもはやメーカーのサポセンに聞き時なのかも
     (内部事情を知っていたりする
      あのカニじゃあやっぱりだめだったか等
     結局送ってくれということになって
     新品(相当品?)が貰えるような気がしてならず
  • id:yoshidako
    /pcilock
    も試してみましたが・・・どうも上手くいかなかった。
    そもそもこのマザボとBIOSではPCIに固定のIRQを
    割り付けることが出来なさそうなのです。
    何か勘違いしているのかも知れないのですが。
    IRQについてはマザボのサポートに問い合わせるのが近道だとは
    思いますが、とりあえずオーディオカードを修理に
    出してしまうことにします。

    音には定評がありますが、
    安定性はあまり良くないカードということに
    なっているのですが、さてさてどんなことになりますか。

    しかし、Bootオプションにはこんなに色々なのが
    あるのですね。
    今回、お答えいただいたお二方にはとても勉強させてもらいました。
    お付き合いくださいましたkurukuru-nekoさん、pasosaviさん、
    ありがとうございました。


  • id:kurukuru-neko

    Creativeの乱ははづづく・・・・・
    ですか

    がんばってください。

    送る前にデジカメで写真でも取っておくとよいですよ。
    シリアルとかRevとかも



この質問への反応(ブックマークコメント)

トラックバック

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません