サーバがたまに(1週間に1回くらい)ネットワークに繋がらなくなり困っています。


サーバのネットワーク構成は下記の通りです。
・OSはWindows Server 2003
・NICが2つ付いている。
・1つのNICはスイッチ(L2)経由で外部(インターネット)に接続していて、グローバルIPアドレス
・もう1つのNICは内部LANに接続していて、プライベートIPアドレス
・デフォルトゲートウェイは1つ目(外部接続)の方を使っている

繋がらない場合の状況は下記の通りです。
・外部接続の方が繋がらなくなる。
・PINGも届かない
・内部接続の方からサーバにログオンし、「ネットワーク接続」の外部接続の方のプロパティを右クリックして、「修復」を実行すると回復する(繋がるようになる)
・繋がらない時にも、タスクトレイにはそれらしいアイコンは表示されない。(※以前片方のNICを使っていなかった時にはネットワークに繋がっていないことを示すアイコンが表示されていた。)
・Windowsのイベントビューアを見ても、エラー等のログは出ていない。

とりあえずどこから調べてよいかもわからず困っています。何かアドバイスをお願いします。

回答の条件
  • 1人2回まで
  • 登録:2006/09/01 13:40:00
  • 終了:2006/09/04 09:46:42

ベストアンサー

id:kurukuru-neko No.5

kurukuru-neko回答回数1844ベストアンサー獲得回数1552006/09/03 19:28:34

ポイント23pt

>監視ツールはNagiosとかでもいいですかね。

定期ポーリングとログが記録できれば

何でもよいと思います。

Server(SMP)環境が最近の主流になっているので

NICは、SMPに公式対応表明しているもの。

>ネゴシエーションの設定で解決できればよいのですが。

ルータ・サーバースイッチ全て固定できる

ものは全て速度,Full/Halfを固定した方がよいです。

停電や電源ON/OFFの順番で想定外でリンクで通信が

確率されるのを防止はできるとおもいますが。

今回のような定期的になるというのはあまり聞きません。

AUTO MDI/MDI-Xも当然固定効。

 

id:karuib

ありがとうございます。

いろいろ勉強になりました。

調査しながら一つずつ、いじってみます。

2006/09/04 09:44:22

その他の回答(4件)

id:kurukuru-neko No.1

kurukuru-neko回答回数1844ベストアンサー獲得回数1552006/09/01 15:33:12

ポイント23pt

現在利用しているドライバーを調べる。

1.メーカー製ドライバーの場合

最新ドライバーに更新する。

2. MS製ドライバーの場合

ドライバの更新で強制的に最新に入れ替える。

更新されない場合は、メーカー製に入れ替える。

===============================================

一部のWindows 2003 Server対応と記載のない

NICや少し古めのNICで長時間使うと何故か

質問と同様の症状に陥ります。


定期的に落ちる場合、落ちる時間がを調べる為の

監視ツールでの監視を行い情報収集も必要です。

(MIB/SNMPの方がよいですが)

http://www.twise.co.jp/frame.html

http://search.vector.co.jp/search?query=ping+%8A%C4%8E%8B

id:karuib

ありがとうございます。そうですね、ドライバーの調査をしてみます。

監視ツールの情報もありがとうございます。監視ツールはNagiosとかでもいいですかね。

2006/09/03 17:22:22
id:mutsuju No.2

mutsuju回答回数551ベストアンサー獲得回数352006/09/01 13:54:45

ポイント23pt

>外部接続の方のプロパティを右クリックして、「修復」を実行すると回復する(繋がるようになる)

外部側はdhcpクライアントですか?

経験から十中八九までNICがさぼっていると思うのですが、大穴としてL2の接続ポートを変えてみるのもアリかもしれません。

あとはネゴシエーションをauto-autoじゃなくて100か1000かで固定してみるとか。

id:karuib

ありがとうございます。外部側はDHCPではありません。

L2のポート変更もやてみようかと思います。(藁にもすがるように...)

ネゴシエーションは思いつきませんでした。たしかに怪しいですね。実は外部の方が接続しているスイッチが1000Mbpsで、内部の方が接続しているルータが100Mbpsなので、その影響もあるんですかね?ネゴシエーションの設定で解決できればよいのですが。

2006/09/03 17:30:34
id:aiaina No.3

aiaina回答回数8179ベストアンサー獲得回数1312006/09/01 16:33:03

ポイント8pt

サーバー側のメンテの可能性もありますね

問い合わせてみてはどうでしょうか

id:karuib

ありがとうございます。

2006/09/03 17:31:17
id:maitaso No.4

maitaso回答回数24ベストアンサー獲得回数02006/09/01 14:59:56

ポイント23pt

修復を下記のリンクにあるようなコマンドで順に実行するとどこが問題かある程度絞れると思いますので、つながらなくなった時にためしてみてください。

http://www.atmarkit.co.jp/fwin2k/win2ktips/355netrepair/netr...

id:karuib

ありがとうございます。こういう原因調査の具体的方法は助かります。

2006/09/03 17:35:45
id:kurukuru-neko No.5

kurukuru-neko回答回数1844ベストアンサー獲得回数1552006/09/03 19:28:34ここでベストアンサー

ポイント23pt

>監視ツールはNagiosとかでもいいですかね。

定期ポーリングとログが記録できれば

何でもよいと思います。

Server(SMP)環境が最近の主流になっているので

NICは、SMPに公式対応表明しているもの。

>ネゴシエーションの設定で解決できればよいのですが。

ルータ・サーバースイッチ全て固定できる

ものは全て速度,Full/Halfを固定した方がよいです。

停電や電源ON/OFFの順番で想定外でリンクで通信が

確率されるのを防止はできるとおもいますが。

今回のような定期的になるというのはあまり聞きません。

AUTO MDI/MDI-Xも当然固定効。

 

id:karuib

ありがとうございます。

いろいろ勉強になりました。

調査しながら一つずつ、いじってみます。

2006/09/04 09:44:22

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません