phpmyFAQをXREAに設置したいのですが、サーバーの仕様は、プログラムの仕様を満たしておりますでしょうか?

不具合とかバグではないのサーバー管理者にも伺えず、かといって、けんさくしてみたのですが、XREAを使っていそうなphpmyFAQ利用者様も見つからず、XREAで動くのかわかりません。
ご教授ください。

phpmyFAQ
http://www.phpmyfaq.de/requirements.php

XREA
http://www.xrea.com/?action=adfree

回答の条件
  • 1人3回まで
  • 登録:2006/09/23 16:27:01
  • 終了:2006/09/24 23:18:27

ベストアンサー

id:worstman No.3

最低人間回答回数121ベストアンサー獲得回数62006/09/23 19:31:27

ポイント40pt

バージョンは1.6.1にて運営しています。

テンプレート以外に手を加えた部分はありません。


考えられる原因ですが、恐らくは

1、XREA管理画面からデータベース作成の際にUTF-8を選択し忘れた

2、XREAサーバの設定の問題

の二つが考えられます。


前者はそのまんまですが、後者はちょっとややこしいです。

実はXREAのサーバは一見同じ仕様でも、内部の設定がサーバごとに微妙に異なっていたりします。

恐らくmbstring の設定が怪しいと思われますので、

adminフォルダ と同じ階層に .htaccess ファイルを作成し、


php_flag mbstring.internal_encoding = UTF-8

php_flag mbstring.http_output = UTF-8

php_flag mbstring.encoding_translation = On


あたりを中身に入れてやればよいかと思います。

id:ps3psp

う~ん。ご指示いただいたことを挑戦してみましたが、上記現象が、やっぱり、治らないです。


【追記】

なかなかプログラムを変更しても埒が開かず、頭来たので、ご指摘の内容でもありましたが、サーバーを変えてみたら、正常動作しましたw

ありがとうございました。

2006/09/24 23:16:17

その他の回答(2件)

id:saphil No.1

saphil回答回数36ベストアンサー獲得回数32006/09/23 17:23:05

ポイント20pt

phpmyFAQは、PHPとMySQLが使用の条件です。XREAのページを見てみましたが両方とも使用できるようです。


phpmyFAQは、Web上でインストール可能ですので、FTPが使えれば大丈夫です。


また、PHPも、.htaccess で設定変更ができるようですので、XREAの問題点は見当たりません。


phpmyFAQは、昔インストールしたことがあります。

ソースが文字化けしているファイルがいくつかあり、それを取り除いていかないとインストールでエラーが発生していました。

また、多言語化がされていますので、UTF-8がベースになります。

id:ps3psp

ご返答ありがとうございます。

やはり仕様的には対応しているんですね

では、自分のインストールの仕方が問題なのかな

もうちょっと研究してみます

ありがとうございました

2006/09/23 18:45:37
id:worstman No.2

最低人間回答回数121ベストアンサー獲得回数62006/09/23 17:32:12

ポイント20pt

http://www.value-domain.com/xreaip.php?action=all#bottom

http://winmxman.net/index.php

s214.xrea.com にて稼動させています。

実際には独自ドメインにて運営しています。

すなわち、PHP 5.1.4、MySQL 5.0.22 で稼動していることになります。

XREAのほとんどのサーバーでphpMyFAQの必要条件を満たしていると考えて差し支えありません。

データベースの文字コードはUnicode(UTF-8)で運用するのがよいかと思います。

id:ps3psp

ご返答ありがとうございます

実際、私、インストールして動作させてみたのですが、カテゴリ作成時、日本語を受け付けず、空欄になってしまう現象が見られるんです。

英数字は問題ないのですが・・・・

なので、仕様がいけないのかな・・・と思ったんですが、私、Ver1.6.5なのですが、どのバージョンを使用されていますか?(鯖はs212です。)

ダウンロードしたものをそのままFFFTPでインストールしたのですが、何か手を加えてますか?

もしよければ、手順などをご教授していただけると助かりますが、差し支えなければお願いします

2006/09/23 18:52:04
id:worstman No.3

最低人間回答回数121ベストアンサー獲得回数62006/09/23 19:31:27ここでベストアンサー

ポイント40pt

バージョンは1.6.1にて運営しています。

テンプレート以外に手を加えた部分はありません。


考えられる原因ですが、恐らくは

1、XREA管理画面からデータベース作成の際にUTF-8を選択し忘れた

2、XREAサーバの設定の問題

の二つが考えられます。


前者はそのまんまですが、後者はちょっとややこしいです。

実はXREAのサーバは一見同じ仕様でも、内部の設定がサーバごとに微妙に異なっていたりします。

恐らくmbstring の設定が怪しいと思われますので、

adminフォルダ と同じ階層に .htaccess ファイルを作成し、


php_flag mbstring.internal_encoding = UTF-8

php_flag mbstring.http_output = UTF-8

php_flag mbstring.encoding_translation = On


あたりを中身に入れてやればよいかと思います。

id:ps3psp

う~ん。ご指示いただいたことを挑戦してみましたが、上記現象が、やっぱり、治らないです。


【追記】

なかなかプログラムを変更しても埒が開かず、頭来たので、ご指摘の内容でもありましたが、サーバーを変えてみたら、正常動作しましたw

ありがとうございました。

2006/09/24 23:16:17

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません