【Apache】Apacheのhtdocsディレクトリではない所にphpMyAdminを入れているのですが、どうやってブラウザからアクセスしたらよいか教えてください

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/09/26 16:27:25
  • 終了:2006/10/03 16:30:03

回答(3件)

id:tokuya_n No.1

tokuya_n回答回数56ベストアンサー獲得回数72006/09/26 16:42:30

ポイント27pt

とりあえず、Apacheから見える(アクセスできる)ロケーションに設置されている必要があります。

ディレクティブと設定変更についてはこちら

http://www.stackasterisk.jp/tech/systemConstruction/apache02_03....


また、Apacheにアクセス権のあるディレクトリに設置されている必要もあります。

その前提で

config.inc.php にURIを設定する項目($cfg['PmaAbsoluteUri'] = 'http://サーバ名(ドメイン)/phpMyAdmin/';)があるのでここを編集すれば良いと思います。

詳しくはこちら。

http://www.dream-seed.com/pukiwiki/index.php?Linux%2FphpMyAdmin%...

id:pandeiro_jp

ローカル環境なので

$cfg['PmaAbsoluteUri'] = 'http://localhost/phpMyAdmin/';

でいいかと思うのですが

うまくいきません・・・。

2006/09/26 17:07:09
id:askul No.2

askul回答回数1ベストアンサー獲得回数02006/09/26 17:39:08

ポイント27pt

Apacheの設定を変更できるようならば、httpd.conf等でAliasディレクティブを追加してみてください。

Alias /phpMyAdmin/ "/doko/kano/directory/phpMyAdmin/"

httpd.confの標準設定にも、Alias設定がどこかにあると思うので、そちらも参考にしてください。

http://www.atmarkit.co.jp/flinux/rensai/apache06/apache06.html

古いですが、1.3/2.0/2.2系で差はないと思います。

id:tokuya_n No.3

tokuya_n回答回数56ベストアンサー獲得回数72006/09/26 18:08:46

ポイント26pt

PHPはインストールされていますか?

また、正しく設定されていますでしょうか?

バージョンが分かりませんが、まあPHP4だと仮定して

Linuxは

http://oss.kk-ntc.co.jp/jpug/pukiwiki/pukiwiki.php?PHP(Linux%C8%C7)%A5%A4%A5%F3%A5%B9%A5%C8%A1%BC%A5%EB

Windowsなら

http://2php.jp/php/install_php_windows.html

辺りの情報が参考になると思います。

Apache, PHP, phpMyAdmin何れも, OSやバージョンによって設定方法が結構違います。

何がインストールされているのかなど、環境周りの情報を明記していただけると、もっとストレートな回答がもらえると思うのですが。

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません