xreaでPHPを使用していてsafe modeがらみのエラーが出てきて困っています。


モジュールとしてではなく、CGIとしてなら、safe modeがoffらしいので、モジュール版のPHPに変更をいけずに、htaccessなどで、cgi版として動作させることはできないのでしょうか?

回答の条件
  • 1人5回まで
  • 登録:2006/10/09 16:12:07
  • 終了:2006/10/09 23:19:59

ベストアンサー

id:shun262 No.2

shun262回答回数95ベストアンサー獲得回数32006/10/09 18:19:20

ポイント40pt

こちらにありますね。

http://sb.xrea.com/showthread.php?t=10744

.htaccessに

AddHandler application/x-httpd-phpcgi .php

と、書けばそのディレクトリ内の*.phpはCGIモードで動作するようです。

しかし、この場合はCGIとして動作させるのでPHPの特徴である「快適」さが失われます。負荷もある程度かかるので、できるならばsafemodeでも動くようなPHPコードにするほうがよいでしょう。

id:iiiiiiiii

あら、すごい。これを試してみます。

2006/10/09 21:52:46

その他の回答(1件)

id:b-wind No.1

b-wind回答回数3344ベストアンサー獲得回数4402006/10/09 17:20:27

ポイント30pt

http://www.xrea.com/?action=faq#8

CGIとして(SafeModeなし)でご利用可能頂く場合は、先頭行に#/usr/local/bin/phpを入れ、拡張子を.cgiにして実行して下さい。

.php 拡張子のまま CGI として動かす事は出来ますが、xrea で可能かどうかは分かりません。

ただし、先頭行の変更は必須です。

http://httpd.apache.org/docs/2.0/ja/mod/mod_mime.html#addhandler

AddHandler cgi-script .cgi
id:iiiiiiiii

やはり先頭行は必須ですか。

2006/10/09 21:52:21
id:shun262 No.2

shun262回答回数95ベストアンサー獲得回数32006/10/09 18:19:20ここでベストアンサー

ポイント40pt

こちらにありますね。

http://sb.xrea.com/showthread.php?t=10744

.htaccessに

AddHandler application/x-httpd-phpcgi .php

と、書けばそのディレクトリ内の*.phpはCGIモードで動作するようです。

しかし、この場合はCGIとして動作させるのでPHPの特徴である「快適」さが失われます。負荷もある程度かかるので、できるならばsafemodeでも動くようなPHPコードにするほうがよいでしょう。

id:iiiiiiiii

あら、すごい。これを試してみます。

2006/10/09 21:52:46

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません