現在、下記の運用をしている環境があります。

今回ルーターが不調になり、YAMAHA社 RT58iへ交換テスト中です。

  [CISCO VPN3000 Concetrator /2port]
(xx.yy.zz.197/29) (192.168.1.200/24)
   |         |
   |    [L2 Dumb Switch/24port]-[PC]
   |         |
 (LAN Port1)  (LAN Port2) Local: 192.168.1.2/24
   [NTT-ME BA5000 SOHO]  Global: xx.yy.zz.193/29
     (WAN Port) LAN型PPPoE/xx.yy.zz.192
       :
    [相手側 CISCO]
       |
 (相手方Private LAN 10.10.0.0/16)

で、RT58iに変えると、外のサイトへの接続は出来るのに相手側の
Private(10.10.0.10等)への通信がNGです。BA5000に戻すと通信が
復旧します。

BA5000でのSTATIC ROUTE設定は[10.10.0.0/16 GW:192.168.1.200]
でしたので、RT58iの方にも
ip route 10.10.0.0/16 gateway 192.168.1.200
を記述しています。

Firewall/Filterlingはテストなので完全スルーにしていますし、
機器Addressは固定割付、DHCP機能はOFFです。
ここが怪しいとか、ここでポカミスをしているはずといった
ご指摘がいただけると幸いです。
(YAMAHAのオフィシャルサイトは確認済み)

回答の条件
  • 1人10回まで
  • 登録:2006/10/13 12:32:05
  • 終了:2006/10/19 16:37:40

回答(4件)

id:b-wind No.1

b-wind回答回数3344ベストアンサー獲得回数4402006/10/13 13:04:35

ポイント35pt

いただいている図からはちょっと状況がよく分からないんですが、BA5000 から RT58i へのリプレースで、Cisco 同士でインターネットVPN を構築していると言う事でいいんでしょうか?

実は NAT/IP masquerade の設定が必要とか?

あとはPCのデフォルトゲートウェイってどうなってるんでしょうか?

id:Harunaha

ありがとうございます。

>いただいている図からはちょっと状況がよく分からないんですが、

>BA5000 から RT58i へのリプレースで、Cisco 同士でインターネット

>VPN を構築していると言う事でいいんでしょうか?

はい、構成目的はご指摘の通りです。インターネットVPN経由で、Private

サーバーにリモート接続(telnet等)を行っています。

BA5000の設定に関しては、前任者(諸般の理由で退職)が設定した構成のまま

特に変更しない状態で引き継いだのですが、ほとんど資料としては残ってい

ない状況です。


>実は NAT/IP masquerade の設定が必要とか?

一応、RT58iのconfigに下記のような記述を入れています。

ip route default gateway pp 1

ip pp nat descriptor 1000

nat descriptor type 1000 masquerade

nat descriptor address outer 1000 xx.yy.zz.193

nat descriptor static 1000 1 xx.yy.zz.193=192.168.1.2 1

>あとはPCのデフォルトゲートウェイってどうなってるんでしょうか?

こちらのほうは

IP アドレス: 192.168.1.105

サブネット マスク: 255.255.255.0

デフォルト ゲートウェイ: 192.168.1.2

DHCP サーバー: 192.168.1.10

DNS サーバー: ww.ww.ww.01, ww.ww.ww.02

WINS サーバー:

という感じです。

2006/10/13 13:52:00
id:b-wind No.2

b-wind回答回数3344ベストアンサー獲得回数4402006/10/13 15:30:43

ポイント30pt

すいませんが接続図がよく分からないのと、Cisco の方の設定が不明なので、解決策は提示できないのですが

PC の方で以下の設定を行ってみてはどうでしょうか?

route add 10.10.0.0 mask 255.255.0.0 192.168.1.200
id:Harunaha

ありがとうございます。

残念ながら、状況は変わりませんでした。

未だ、解決しておりませんが、おおむねCISCO VPN装置間の問題と判断できたので、一旦Closeさせていただきます。

2006/10/19 16:28:15
id:kurukuru-neko No.3

kurukuru-neko回答回数1844ベストアンサー獲得回数1552006/10/13 19:16:41

ポイント10pt

VPNの設定をしていますか?

BA5000の全ての設定を確認まずリストアップ

パススルー PPTP/L2TP/IPsec をRT58i

のコマンドに変えて正しく設定する。

http://www.ntt-me.co.jp/bar/ba5kp_index.html

http://netvolante.jp/solution/vpn/index.html

id:Harunaha

ありがとうございます。

ちなみに、ROUTERの機種はPROでは無くSOHOのため、ご案内のページはあまり参考となりませんでした。すみません。

(SOHOなので、VPN関係のFunctionもない、ベタな機種のはずですし、プライベートを含めた設定も、全てそのまま持ってきているはずなのですが...(^^;))

また、パススルーについては、質問に記述の通り、全てスルーの設定でやっておりますので、特に問題となるポイントを見つけることは出来ませんでした。

未だ、解決しておりませんが、おおむねCISCO VPN装置間の問題と判断できたので、一旦Closeさせていただきます。

2006/10/19 16:33:22
id:relaxuma No.4

relaxuma回答回数56ベストアンサー獲得回数12006/10/14 11:10:29

ポイント15pt

BA5000の構成は以下が参考になるかもしれません。

http://www.ntt-me.co.jp/bar/ba512_lan-pppoe-settei.html

RTの設定は以下が参考になるかもしれません。

http://www.rtpro.yamaha.co.jp/RT/docs/example/ocn-economy5.html

RT58iにて

LAN側のsecondaryIPに xx.yy.zz.193/29 が必要かと思います。

id:Harunaha

ありがとうございます。

SecondaryIPについて再確認いたしましたが、RT58iのconfig上で、確かに記述しておりますので、こちらも要因ではないようです。

未だ、解決しておりませんが、おおむねCISCO VPN装置間の問題と判断できたので、一旦Closeさせていただきます。

2006/10/19 16:34:52

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません