これからjavaを勉強しようと思うのですが、http://java.sun.com/j2se/1.3/ja/download.html ←ここのJREからダウンロードしてコマンドプロンプトでコンパイル「javac」を入力したら、認識されていない旨の結果が返ってきました。WINXPでダウンロードした後にやるPATH変数の設定方法やその他やらなければいけないことを教えてください。

回答の条件
  • 1人2回まで
  • 登録:2006/11/04 10:22:26
  • 終了:2006/11/04 12:41:42

回答(4件)

id:garyo No.1

garyo回答回数1782ベストアンサー獲得回数962006/11/04 10:39:27

ポイント30pt

http://www.tohoho-web.com/java/start.htm#JDK

こちらの「環境を設定する」を参考にパスを設定すれば認識するようになりますよ。

id:keronimo

システム環境変数を変更してしまったのが原因かも??基の値を保存し忘れてしまった!!

ホームエディションだったらこっちの値もおしえてもらえませんか?

2006/11/04 11:00:52
id:STRing No.2

STRing回答回数351ベストアンサー獲得回数362006/11/04 10:40:18

ポイント20pt

インストールガイド

本当に JRE を落としているならそれはランタイムだけだったような。

っていうか、バージョンが古いのはなぜでしょうか?

id:keronimo

何年か前の本を見ていたもので(^_^;

違う方をインストールします。

2006/11/04 12:07:30
id:teruhito0918 No.3

teruhito0918回答回数4ベストアンサー獲得回数02006/11/04 10:57:19

少し古いですがpathの設定から

基本(Hello worldの出し方)

など色々載っていますので

私が使用した本

java入門の入門/坂下夕里 薯

を参照にしてみてはどうでしょうか?

id:keronimo

本の紹介はいりません。

2006/11/04 12:39:49
id:un0 No.4

un0回答回数651ベストアンサー獲得回数322006/11/04 11:02:24

ポイント40pt

JREにはjavacは入っていませんので、SDKのほうをダウンロードしてください。

JRE

Windows Platform - Java(TM) 2 Runtime Environment, Standard Edition 1.3.1_19

(j2re-1_3_1_19-windows-i586-i.exe 7.94 MB)

SDK

Windows Platform - Java(TM) 2 SDK, Standard Edition 1.3.1_19

(j2sdk-1_3_1_19-windows-i586.exe 31.83 MB)

id:keronimo

バージョンが古かったようです。

2006/11/04 12:39:52
  • id:karasimiso
    http://java.sun.com/j2se/1.5.0/ja/download.html
    Windows98以前のバージョンで開発するのでなければ最新版を使った方がいいと思いますよ。そのバージョンだと正規表現などが使えなかったような気もしますし。
  • id:keronimo
    バージョンの指摘ありがとうございます。ダウンロード対象がいっぱいありすぎたので別のサイトで確認しました。無事にコンパイルできたので助かりました。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません