PHPを学習しています。

現在のバージョンが5.2ですが、テキストと食い違う点が多くなってきました。
そこで他のバージョンの5.10または5.11を入手したいと思っています。
どこで入手できるでしょうか。

一応現在直面している問題点を挙げると、
5.2ではPDO関数を利用することができますがPEARのインストールがうまくいきません。
古いタイプの5.01ではPEARのインストールはできますがPDO.dllなどが導入できません。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/12/14 20:12:26
  • 終了:2006/12/15 00:24:26

回答(3件)

id:guesthouse No.1

guesthouse回答回数51ベストアンサー獲得回数02006/12/14 22:03:57

ポイント20pt

「PHP5.2.0 には同梱される go-pear.bat スクリプトに不都合があります」

http://blog.goo.ne.jp/g_suzu/e/cf4dde22ce1d9950a349315bbea08800

ということで、リンク先にあるような手順でPEARを設定すれば、PHP5.2.0のままでいけると思います。

id:plugbot

書き間違えました。pearのインストールはできて(go-pear.batとpearフォルダ内のスクリプト変更)ライブラリのインストールができないのです。

could not open xxx for writing

とエラーが出てとまったままです。

どちらにしても原因がわからないのでまずはテキストのバージョンをあわせて学習を進めようと考えています。

2006/12/14 22:19:20
id:kronecker No.2

kronecker回答回数88ベストアンサー獲得回数102006/12/14 22:44:26

ポイント35pt

http://jp.php.net/releases/index.php

PHPについては全く知らないけどここって公式サイトじゃないの?

5.10とか5.11ってバージョンはないけど…

もし5.1.0や5.1.1の間違いなら上記サイトで入手できます。

id:plugbot

ここですね。ありがとうございます。

2006/12/15 00:22:58
id:b-wind No.3

b-wind回答回数3344ベストアンサー獲得回数4402006/12/14 23:58:13

ポイント25pt

http://jp.php.net/releases/index.php

こちらに過去のバージョンの一覧があります。

お好きなものをどうぞ。

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません