PHPを使ってGoogleMapAPIを簡単につかってみるために、PEARにhttp://www.phpinsider.com/php/code/GoogleMapAPI/からペッケージをダウンロードしてターミナルでpear install 'パッケージの場所'とやってみましたが、

Cannot initialize '/Users/admin/Desktop/GoogleMapAPI-2.3.tar.gz', invalid or missing package file
Package "/Users/admin/Desktop/GoogleMapAPI-2.3.tar.gz" is not valid
install failed
とでてしまいます。
解決方法ご存知の方教えていただけますか?
開発環境はMacosxに、MAMPを通して使っています。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2007/02/03 23:26:43
  • 終了:2007/02/04 01:17:34

回答(1件)

id:toohigh No.1

toohigh回答回数291ベストアンサー獲得回数372007/02/03 23:41:27

ポイント60pt

GoogleMapAPI-2.3.tar.gz は PEAR パッケージではないので、

# tar zxvf GoogleMapAPI-2.3.tar.gz

・・・という感じで展開して、出てきたGoogleMapAPI.class.phpを

require で読ませれば使えます。

http://q.hatena.ne.jp/

id:makotoworld

PEAR初心者でわからなかったです。

本当にありがとうございます。

2007/02/04 01:17:13

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません