Debianで

perl -MCPAN -e shell
cpan[2]> upgrade ExtUtils::XSBuilder
を実行すると
---
I could not find your OpenSSL in `'
Please provide OpenSSL-0.9.6j or
OpenSSL-0.9.7b installation directory (get from
http://www.openssl.org/ if you don't have it; please note that
SSLeay is no longer supported, see README) (C-c to abort):
---
というメッセージで停止します。
現状は、CTRL+Cで中断するしかないんですが、これを解決するにはどうしたら良いんでしょうか?

OpenSSLは、
apt-get install ssh
でインストール済みです。
dpkg -l | grep ssl
ii openssl 0.9.7e-3sarge4 Secure Socket Layer (SSL) binary and related

回答の条件
  • URL必須
  • 1人1回まで
  • 登録:2007/02/21 14:21:19
  • 終了:2007/02/21 14:52:34

ベストアンサー

id:Tietew No.1

Tietew回答回数12ベストアンサー獲得回数42007/02/21 14:31:18

ポイント55pt

http://packages.debian.org/stable/perl/libextutils-xsbuilder-per...

ExtUtils::XSBuilder はパッケージでありますよ。

apt-get install libextutils-xsbuilder-perl

で入ります。

どうしでもCPANモジュールでコンパイルしたいという場合は「開発用ライブラリ」が必要です。libssl-dev パッケージをインストールしてください。

id:P-mako

上手くいきました。ありがとうございます。

2007/02/21 14:49:37

その他の回答(1件)

id:Tietew No.1

Tietew回答回数12ベストアンサー獲得回数42007/02/21 14:31:18ここでベストアンサー

ポイント55pt

http://packages.debian.org/stable/perl/libextutils-xsbuilder-per...

ExtUtils::XSBuilder はパッケージでありますよ。

apt-get install libextutils-xsbuilder-perl

で入ります。

どうしでもCPANモジュールでコンパイルしたいという場合は「開発用ライブラリ」が必要です。libssl-dev パッケージをインストールしてください。

id:P-mako

上手くいきました。ありがとうございます。

2007/02/21 14:49:37
id:iwaim No.2

iwaim回答回数215ベストアンサー獲得回数192007/02/21 14:34:41

ポイント15pt

libnet-ssleay-perlパッケージをインストールするとどうでしょうか。

http://packages.debian.org/stable/perl/libnet-ssleay-perl

id:P-mako

1番目の方の回答で、上手くいきました。ありがとうございます。

2007/02/21 14:49:40
  • id:iwaim
    あ、しまった。凄く勘違いしている回答になってます。今気づきました。ポイント返しておきます。すみません。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません