現在、JAVAランタイム 1.3.1_06がはいっているPCがあるのですが、

そのPCで、1.4.2以上のものを導入して、WEBアプリケーションごとに
アプレットのバージョンを切替えて使用できないか模索しています。
(OSはXP SP2,ブラウザはIEを使用)

下記サイトにある方法は試してみたのですがうまくいきません。
なにか切替える方法はあるのでしょうか?

http://www.atmarkit.co.jp/bbs/phpBB/viewtopic.php?topic=34695&forum=12&6
http://oshiete1.goo.ne.jp/kotaeru.php3?q=1353767

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2007/04/16 10:19:15
  • 終了:2007/04/20 19:25:54

回答(2件)

id:wnagata No.1

wnagata回答回数170ベストアンサー獲得回数182007/04/16 21:19:35

ポイント40pt

http://java.sun.com/j2se/1.4.2/docs/guide/plugin/developer_guide...

に複数バージョンをサポートしてあると書いてあるのですが、

最後の最後に、Multiple versions of the JRE can be run in different browser sessions. However, multiple versions can not be run in the same browser session. Should this be attempted, the user is warned and the attempt will fail.と注釈されています。要するにIEを立ち上げなおさないと、異なるバージョンのJREには切り替えられないということですね。IEを立ち上げる前に使用するJREを設定しておかないといけないということですから、うまく切り替える方法はないようです。IEとFirefoxなどの別のブラウザを使用するのが、もっとも便利な方法でしょう。

id:rinka-lv

ご回答ありがとうございます。IEとNetscapeやFirefoxで試してみたのですがうまくいかないようです。やっぱりダメみたいですね。

2007/04/18 19:50:09
id:hallo21 No.2

hallo21回答回数246ベストアンサー獲得回数22007/04/17 03:01:30

id:rinka-lv

ご回答ありがとうございます。MicrosoftVMが入手できるなら試してみたいですね。

2007/04/18 19:53:47

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません