携帯のホームページ(docomo)をxhtmlで作成しています。以下のようにしてみたのですが、CSSが反映されません。どこかに誤りがあると思うので、どなたか指摘願います。


①CSS外部ファイル:main.css
.line_01 {
background:url(line_0113.jpg) repeat-x;
height:20px;
padding:3px;
text-align:center;
}

②HTML:test.html
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml xml:lang="ja">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=euc-jp"/>
<meta http-equiv="Content-Style-Type" content="text/css"/>
<meta http-equiv="Content-Script-Type" content="javascript"/>
<meta http-equiv="Content-Language" content="ja"/>
<title></title>
</head>
<link href="main.css" rel="stylesheet" type="text/css">
<body>
<br>
<br><br>
<font size="1" color=#FFFFFF><div class="line_01">メニュー</div></font>
</body>
</html>

③.htaccess
AddType application/xhtml+xml .html

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2007/04/20 14:55:23
  • 終了:2007/04/20 16:30:14

回答(3件)

id:kidd-number5 No.1

kidd-number5回答回数117ベストアンサー獲得回数152007/04/20 15:19:51

ポイント27pt

</head>

<link href="main.css" rel="stylesheet" type="text/css">


<link href="main.css" rel="stylesheet" type="text/css">

</head>

か?

最初に構文チェックしておいたほうが良いかも。

http://htmllint.itc.keio.ac.jp/htmllint/htmllint.html

id:Mase

構文の誤りを修正してみましたが、やはりドコモでは表示できませんでした。ちなみに、auではCSSが反映されます。

2007/04/20 15:29:36
id:mj99 No.2

mj99回答回数138ベストアンサー獲得回数382007/04/20 15:52:23

ポイント27pt

http://www.nttdocomo.co.jp/service/imode/make/content/xhtml/outl...

【i-CSS】

i-CSSは、iモード対応XHTML用のCSSです。

インラインのみに対応しています。

だそうです、、、

id:Mase

やはりそうなんですかねぇ。

2007/04/20 16:04:39
id:studioes No.3

studioes回答回数522ベストアンサー獲得回数612007/04/20 15:58:25

ポイント26pt

http://www.nttdocomo.co.jp/service/imode/make/content/xhtml/char...

 DTDが違うんじゃ。

 と言うか、xmlのエンコーディング指定が必須になっているが書かれていないし、そもそもiMode標準ではUTF8とSJISしか・・・

id:Mase

ここを直しても、CSSは外部ファイルにはできないのでは?

2007/04/20 16:05:51

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません