4月30日にXoops 2.1.0が配布開始されたそうですが、

現在利用中の2.0.16aから2.1.0へバージョンアップするには、
どちらのどのファイルをDLすれば良いのか教えて下さい。

現在利用中の2.0.16aにはモジュール各種が既に稼動中ですので、
配布されている2.1.0をすべてDLしてサーバーにアップ致しますと、
稼動中のモジュールに影響がでると想像しております。


宜しくお願い申し上げます。

回答の条件
  • URL必須
  • 1人10回まで
  • 登録:2007/05/07 11:23:42
  • 終了:2007/05/07 15:26:58

ベストアンサー

id:KazyN No.1

KazyN回答回数352ベストアンサー獲得回数322007/05/07 12:12:30

ポイント120pt

個人的には、特に理由がなければ、今すぐに XoopsCubeLegacy 2.1.0 へアップグレードするのはオススメしません。

なぜならば、今回の 2.1.0 は、従来の Xoops とは、コアの部分から変わっていて、従来のモジュールとの互換性は保たれているとは言いながらも、まだすべて検証しきれていないというのが実情だからです。

どうしてもやるのであれば、まずは以下のページから「XOOPS Cube Legacy 2.1.0」をダウンロード。

http://xoopscube.org/modules/documents/index.php?id=6

その後、以下の説明手順に従って、作業を行います。

http://xoopscube.org/modules/pukiwiki/?XOOPSCubeLegacy%2FHowToUp...

途中で mainfile.php 以外のファイル・フォルダを削除したりと、あらかじめ手順を十分理解しないと危険なため、やるのであればローカルにバックアップ環境を作って試してから臨まれることをオススメします。

id:SumireS

アップグレードではなく、新規に導入という形であれば大丈夫でしょうか?

その場合、現在配布中のいろいろなXoops用モジュールをそこに導入しても不具合が生じる可能性もあるということでしょうか・・・

2.1.0の一つ前のバージョンのまま利用していたほうが安全という事なのですね?

2007/05/07 12:27:23
  • id:KazyN
    新規導入なら基本的に問題はないと思います。
    実際のところ、私もまだこの新しいバージョンは触っていないので、どこがどうとはいえないのですが....

    とりあえずここで、各モジュールの互換性情報が集められているようですので、必要なモジュールについての情報収集をされてから導入すると良いでしょう。
    http://xoopscube.org/modules/pukiwiki/index.php?XOOPSCubeLegacy%2FModuleCompatibility

  • id:SumireS
    KazyN様

    ご指導ありがとうございました。
    お知らせ戴いたURLのページを参考にして、新規導入について検討してみますね。


    KazyNさんが後日、2.1.0を触ってみられる機会がございましたら、
    その感触などを教えて頂けましたら、たすかります。

  • id:b-wind
    http://xoopscube.jp/modules/xhnewbb/viewtopic.php?topic_id=4398&viewmode=flat
    RC版へのアップデート方法だが、ほぼ変わってないはず。
    試してないので期待しないで。
  • id:SumireS
    b-wind様

    コメントありがとうございます。

    b-windさんが、アップデートされる機会がございましたら、
    その前後の様子などを教えて頂けましたら、たすかります。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません