meadow&trampで、リモートPC内のファイルを編集しようとしているのですがうまくいきません。対処方法を教えてください。


■各ソフトのバージョン
・meadow 2.10
・tramp 2002-02-18

■設定内容

・下記サイトを参考に、.emacsを設定しました。
http://www.ep.sci.hokudai.ac.jp/~michi/pc/tips/win-15.html

・tramp関連の設定内容です。エラーになる行があったので、一行コメントアウトしています。
(add-to-list 'load-path "~/.emacs.d/tramp/lisp/")
(require 'tramp)
(setq tramp-default-method "plink")
(setq tramp-completion-without-shell-p t)
(setq tramp-shell-prompt-pattern "^[ $]+")
(setq tramp-debug-buffer t)
(nconc (cadr (assq 'tramp-login-args (assoc "ssh" tramp-methods))) '("/bin/sh" "-i"))
;;(setcdr (assq 'tramp-remote-sh (assoc "ssh" tramp-methods)) '("/bin/sh -i"))
(modify-coding-system-alist 'process "plink" 'utf-8)

■どこがおかしいか
C-x,C-fの後に
/willnet@hoge:/home/willnet/test.txt
とすると、
Opening FTP connection to hoge...
となります。どうやらSSHで接続する設定が有効に反映されていないようです。

■その他
plinkにパスは通っています。

回答の条件
  • 1人3回まで
  • 登録:2007/06/03 14:19:39
  • 終了:2007/06/04 20:12:50

ベストアンサー

id:i_kumagoro No.1

i_kumagoro回答回数170ベストアンサー獲得回数582007/06/04 11:46:10

ポイント100pt

trampのバージョンを上げてください。sourceforgeからダウンロードできる2002年2月18日リリースのファイルを確認しましたがplinkには対応していません。

ちなみに、参照されたサイトで使用しているものでも2.0.39で、2005年のものです。新しいものはGNUのFTPサイトなどからダウンロードできます。

id:willnet

trampを新しいものにして、

meadowも最新のものにしたらできました!

(tramp内のドキュメントに、Emacs ver22以降対応と書いてあったので、meadowのバージョンも上げました)

ありがとうございました!

2007/06/04 20:12:16

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません