PHPプログラムの動作中に下記のエラーが出ます。何をいってるのかもわかりません。対処方法のアドバイスをいただければ幸いです。

ちなみにPHPはバージョンアップをしております。

Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2007/06/28 03:06:26
  • 終了:2007/06/28 08:39:11

ベストアンサー

id:Nigitama No.1

にぎたま回答回数311ベストアンサー獲得回数182007/06/28 03:51:01

ポイント60pt

まずメッセージの内容はこんな感じです。

警告: Unknown(): お使いのスクリプトは、セッションのサイドエフェクトに依存している可能性があります。このサイドエフェクトはPHP 4.2.3 まで存在しています。register_globalsを有効(enabled)にしない限り、セッションエクステンションは、グローバル変数をデータのソースとして認識しません。session.bug_compat_42 または、session.bug_compat_warn をoffにすることで、この機能とこの警告メッセージをそれぞれ無効(disable)にすることができます。

で、解決方法は以下の質問を参照してください。

http://q.hatena.ne.jp/1179382895

id:kaji0245

ご回答ありがとうございます、早速試してみたらOKでした。

2007/06/28 08:38:51

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません