RubyをVine Linux3.2にインストールするときにgzipとtarを使うのですが、オフィシャルのインストールガイドの書き方をもっと短くできませんか?



gzip -dc ruby-1.8.6.tar.gz | tar xf -



Ruby インストールガイド - UNIX全般
http://www.ruby-lang.org/ja/install.cgi?cmd=view;name=UNIX%C1%B4%C8%CC

回答の条件
  • 1人2回まで
  • 登録:2007/07/15 21:19:18
  • 終了:2007/07/17 22:54:27

回答(3件)

id:sentakuita No.1

sentakuita回答回数11ベストアンサー獲得回数02007/07/15 21:46:07

ポイント35pt

Vine3.2にあるapt/rpmをそのまま使うのはNGですか?
# apt-get install ruby

1.8.6で無いと困る、なんて話ならVineSeedから拝借するとか。
$ rpm --rebuild ruby-1.8.6-0vl4.src.rpm
# rpm -Uvh ~/rpm/RPMS/i386/ruby-devel-1.8.6-0vl4.i386.rpm
(i386の場合)

tar+gzipで行くなら tar の -z オプションでしょうか。
tar.gz をまとめて展開します。
$ tar -zxf ruby-1.8.6.tar.gz

id:afternoontea

ok

2007/07/17 22:52:35
id:vh5150 No.2

vh5150回答回数231ベストアンサー獲得回数52007/07/15 23:16:54

ポイント35pt

% tar zxvf ruby-1.8.6.tar.gz

% cd ruby-1.8.6

% ./configure

% sudo make && make install

ではダメでしょうか.

./configure, make, make installを省くのはデフォルトでは無理だと思います.

id:afternoontea

ok

2007/07/17 22:52:29
id:YasuyukiMiura No.3

ココサブ回答回数33ベストアンサー獲得回数72007/07/16 02:07:12

ポイント10pt

確認していませんが、


$ ./configure

$ sudo make install


でも大丈夫な可能性はあります。

id:afternoontea

ng

2007/07/17 22:52:22
  • id:Bookmarker
    GNU tar なら
    tar zxf ruby-1.8.6.tar.gz
    です。

    tar(1):
    http://www.freebsd.org/cgi/man.cgi?query=tar&apropos=0&sektion=0&manpath=Red+Hat+Linux%2Fi386+9&format=html

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません