【ネットワークドライブ】


3台のPC(WinXPとWin2000混在)で、LAN接続をしています。

ルータやDHCPサーバはなく、それぞれ手動でIPを割り振っています。

ワークグループの名称は同じです。

PC名は、
・client01
・client02
・client03
としています。

client02とclient03から、client01を参照すると、共有フォルダを見ることができます。

その共有フォルダを02と03にネットワークドライブとして、起動時に自動的に接続するようにしました。

さて、ここで問題が発生しました。

02や03で、起動後、エクスプローラからネットワークドライブを開くと問題なく開けるのですが、

エクスプローラでネットワークドライブを開く前に、
桐というデータベースソフトの参照先をネットワークドライブのz:にして起動すると、
「開けませんでした」とエラーメッセージが出ます。

先にエクスプローラからネットワークドライブを開いてから、桐を立ち上げると、正常に開けます。

考えられる原因と解決方法をご存じの方がいらっしゃったら、ご教授ください。

回答の条件
  • 1人5回まで
  • 登録:2007/09/01 17:13:50
  • 終了:2007/09/08 17:15:03

回答(2件)

id:wnagata No.1

wnagata回答回数170ベストアンサー獲得回数182007/09/01 20:50:15

ポイント35pt

1. 「ログオン時に再接続する」がチェックされていなければ、チェックしてください

2. 1.でもだめなら、net use コマンドでz:ドライブに接続してから、桐を起動するバッチファイルを使用すればよいでしょう。

http://www.atmarkit.co.jp/bbs/phpBB/viewtopic.php?topic=31301&am...

http://www.iodata.jp/support/advice/hdl_1/htm/map.htm

id:caster777

ありがとうございます。

試してみます。

2007/09/03 17:14:20
id:ohsan1453 No.2

ohsan1453回答回数26ベストアンサー獲得回数12007/09/01 22:30:18

ポイント35pt

以下のURLを参考にしてみてください。

同じように悩んでいる方がいます。

http://www.fuku3.com/~habata/kbbs/kakov9/30553.htm

id:caster777

ありがとうございます。

試してみます。

2007/09/02 15:31:34
  • id:Afrodita
    確認です

    桐というデータベースソフトは、各クライアントにインストールされているのですね?

    そして、クライアント2と3にはクライアント1のデータベースが割り当ててあるフォルダーをネットワークドライブZ:として指定した。

    で、桐というソフトをクライアント2または3から動かすとデータベースが見つからないと言うエラーになる。

    エクスプローラからz:ドライブへのアクセスは出来る。

    アクセス後、桐というソフトはデータベースを認識して動作可能になる。

    と言う事でしょうか
  • id:caster777
    ID:Afroditaさん

    ありがとうございます。

    コメントに書いていただいた内容の通りです。

    補足を付けますと、
    クライアント1から、クライアント1を見に行っても(自分の共有をネットワークドライブにしても)同様の現象が起きます。
    また、XPは、HOMEです。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません