mod_layoutについて

centos4.5でmod_layout4.1を無事インストールしましたが、
AddOutputFilter LAYOUT html
LayoutHeader /home/info/public_html/header.html
を全ページにheader.htmlを出力させようとしましたが,
真っ白な画面画表示されるだけです。
Makefileのパスが違っているのではないかと思いますが、

# the used tools
APXS=/usr/sbin/apxs
APACHECTL=/usr/sbin/apachectl

解決方法がお解かりの方がおられましたらお願いします。

回答の条件
  • 1人5回まで
  • 500 ptで終了
  • 登録:2007/09/19 03:08:53
  • 終了:2007/09/26 03:10:03

回答(5件)

ただいまのポイント : ポイント6 pt / 500 pt ツリー表示 | 新着順
apacheのインストール方法はどうしてますか? keino2007/09/19 13:21:14ポイント3pt
apacheのバージョンやインストール先が不明なので何が悪いのか良く判りませんが、以下の所が参考になるのではないかと思います。 http://yaguma.com/Server/mod_layout.html mod_layoutのパッケージには、必要とするapacheのバージョン ...
回答ありがとうございます cherry-g2007/09/19 17:25:24
リンク先のサイトは参考にしました。 CentOs4.5 apache2.052 mod_layout4.1のインストール先:/usr/local/src mod_layout4.01aでは、うまく動作したのですが、OSの再インストールを行い mod_layout4.01aが見当たらなかったので、mod_layout4.1 ...
Versionの依存関係に問題があるかも keino2007/09/19 20:11:13ポイント2pt
yumでインストールされたのが以下のURLに該当するものかどうかわかりませんが、apacheのバージョンが少し低いみたいです。 http://sea-mew.jp/nox/modules/rpms/el4/apache-mod_layout-4.0.1a-4.1.100mdk.i386.rpm apacheのバージョンを2.0.58まで上げ ...
回答ありがとうございます。 cherry-g2007/09/19 22:26:21
mod_layout4.0.1aのrpmがあるとは知りませんでした。 上記からrpmをダウンロードし #rpm -Uvh apache-mod_layout-4.0.1a-4.1.100mdk.i386.rpm 実行したところ エラー: Failed dependencies: httpd-conf >= 2.0.54 is needed by apache-mod_layout-4.0.1a-4.1.100mdk.i ...
この方法はどうでしょう。 keino2007/09/21 05:35:33ポイント1pt
ご紹介したURLには、4.0.1a のソースもあったはずですが、そちらはコンパイルできませんか? Apacheには2.0.58より前のバージョンには セキュリティ上の問題があるので、こちらをアップグレードした方がいいんですけどね ...
  • id:cherry-g
    回答ありがとうございます。
    間違えてkeino様の投稿欄に書いてしまいました。
    apache2.052
    yum でインストールしました。
    インストール先は、コマンドで
    #whereis httpd で確認したところ、
    /usr/sbin/httpd
    /usr/sbin/httpd.worker
    /etc/httpd
    /usr/lib/httpd
    /usr/include/httpd

    対処策はありますでしょうか。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません