ImageMagickとPerlMagickのインストールについて教えてください。


ImageMagickをインストールし(こっちはできました)
次にPerlMagickをインストールしようとしますがうまくいきません。

# perl Makefile.PL
# make
# make install

としてインストールできると思っていたんですが、

# perl Makefile.PL
WARNING: LDFLAGS is not a known parameter.
Warning: -L../magick/.libs changed to -L/usr/local/src/ImageMagick-6.3.7/PerlMagick/../magick/.libs
Warning: -L../wand/.libs changed to -L/usr/local/src/ImageMagick-6.3.7/PerlMagick/../wand/.libs
Writing Makefile for Image::Magick


↑このように表示されてしまいます。
この原因がわかりますでしょうか?

用途はMT4でサムネイルを利用するためです。

よろしくお願いいたします。

回答の条件
  • 1人3回まで
  • 登録:2007/12/19 16:51:59
  • 終了:2007/12/26 16:55:02

回答(2件)

id:tmasao No.1

tmasao回答回数76ベストアンサー獲得回数202007/12/19 17:34:05

ポイント35pt

上記メッセージは単なる警告メッセージでエラーとなっているわけではないので、無視してよいと思います。

続けて make && make install はできませんか?

id:akahoshitakuya

回答ありがとうございます!

make,make installはできたんですが、

MT4で画像をアップすると以下のようなエラーが出ます。

Deep recursion on subroutine "Image::Magick::AUTOLOAD" at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Image/Magick.pm line 42

それでいろいろ検索した結果

http://forums.majordojo.com/comments.php?DiscussionID=107

に行き当たり、(質問のようなエラーも出ていたし)PerlMagickが

しっかりインストールされていないのかな?

と思ったのです。

上記のエラーはPerlMagickとは関係ないのでしょうか?

よろしくお願いいたします。

2007/12/19 18:55:36
id:ffmpeg No.2

ffmpeg回答回数1202ベストアンサー獲得回数92007/12/20 11:09:27

ポイント35pt

warningはインストールの可否には関係ありません。

id:akahoshitakuya

回答ありがとうございます。

昨日いろいろやったんですが、

phpで作ったサイトだとImageMagickはうまく動作するんですが、

MT4(つまりPerlMagick?)だと

Deep recursion on subroutine "Image::Magick::AUTOLOAD" at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Image/Magick.pm line 42

このエラーが出てしまうのです。

warningがインストールと関係ないということは

インストールはできているが他に問題があるということなのかなー

2007/12/20 15:05:44

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません