ZendCore2に関する質問です。

・WindowsServer2003R2(x86)
・IIS6
・PostgreSQL8.2
・ZendCore2(PHP5.2.1相当)
を動かしています。
ZendCore2(PHP5.2.1相当)で、PostgreSQLエクステンション(php_pgsql.dll)を利用する方法はありますか?
(PDOではないものです。)
ZendCore2にphp_pgsql.dllが含まれていなかったので、
PHP5.2.1.zipから展開したphp_pgsql.dllをZendCore2のphpextフォルダにコピーして、php.iniを手編集しました。
ZendCoreAdministration.Extensionsの画面上に、PostgreSQL項目が追加されたのですが、
!マークがついてしまい、うまくロードできていないようでした。

ZendCore for Postgresは、有償のようですので使用しません。(もし無償でしたら教えて下さると幸いです)
他に情報が必要であれば、コメント欄でご質問下さい。

回答の条件
  • 1人3回まで
  • 登録:2008/01/08 11:41:22
  • 終了:2008/01/09 13:29:28

ベストアンサー

id:devichan No.1

devichan回答回数56ベストアンサー獲得回数42008/01/08 12:08:19

ポイント120pt

私も、やったことがないのでわかりませんが、

以下のような掲載がありました。

http://www.zend.com/forums/index.php?t=msg&th=3418&start=0&S=18c...

(日本語訳)

http://www.excite.co.jp/world/english/web/?wb_url=http://www.zen...

ここで、以下のように言われています。

Please take the .dll file from the PHP 5.2.x NTS binaries. YOu can get those from:

http://www.php.net/get/php-5.2.1-nts-Win32.zip/from/a/mirror

PHP 5.2.x NTS binariesから.dllファイルを取って利用してください。

と言うことのようですので、

一度、「PHP5.2.1.zip」ではなく、

「php-5.2.1-nts-Win32.zip」を利用されてみてはいかがでしょうか?

id:HISI

どうも有難う御座います。日本語翻訳するページは素晴らしいですね。

どうやらズバリのことが書かれているようです。

早速試してみたいと思います。

2008/01/08 23:36:21
  • id:HISI
    どうも有り難う御座いました。
    おかげさまで、無事MediaWiki 1.11.0をPostgreSQL8.2をエンジンに稼動させることができました。
    (http://www.mediawiki.org/wiki/Manual:Installation/ja)

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません