Mac OS X 10.5.1 に Ruby on Rails をインストールしようとしています。


状況は以下の通りです。

Macintosh:~ user$ which ruby
/opt/local/bin/ruby

Macintosh:~ user$ ruby -v
ruby 1.8.6 (2007-09-23 patchlevel 110) [i686-darwin9.1.0]

Macintosh:~ user$ which gem
/Users/user/bin/gem

Macintosh:~ user$ gem -v
1.0.1

Macintosh:~ user$ echo $GEM_HOME
/Users/rubygems

Macintosh:~ user$ sudo gem install rails --include-dependencies
Password:
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
Successfully installed rails-2.0.2
1 gem installed

Macintosh:~ user$ irb
irb(main):001:0> require 'active_support'
LoadError: no such file to load -- active_support
from (irb):1:in `require'
from (irb):1
irb(main):002:0> $:
=> ["/opt/local/lib/ruby/site_ruby/1.8", "/opt/local/lib/ruby/site_ruby/1.8/i686-darwin9.1.0", "/opt/local/lib/ruby/site_ruby", "/opt/local/lib/ruby/vendor_ruby/1.8", "/opt/local/lib/ruby/vendor_ruby/1.8/i686-darwin9.1.0", "/opt/local/lib/ruby/vendor_ruby", "/opt/local/lib/ruby/1.8", "/opt/local/lib/ruby/1.8/i686-darwin9.1.0", "."]

どうすれば Rails を使用できるようになりますか?

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2008/01/10 00:59:12
  • 終了:2008/01/12 01:56:31

回答(1件)

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません