centos5を入れたサーバでWEBサーバを立ち上げています。

yumからapache2.2、php5などをいれてますのが、yumでインストールバージョンが少し古く(httpd-2.2.3-11)
apacheの脆弱性対策などが最新版より遅れている状態です。

最新版のapache2.2.8などの最新版を継続的に掲載しているyumリポジトリの場所などしりませんでしょうか?

自分で構築する場合もあるのですが、できればそういう場所があればなと思っています。

回答の条件
  • 1人3回まで
  • 登録:2008/05/02 14:49:35
  • 終了:2008/05/02 19:22:05

ベストアンサー

id:y-kawaz No.1

y-kawaz回答回数1420ベストアンサー獲得回数2252008/05/02 16:04:53

ポイント60pt

httpd-2.2.3-11 の -11 が見えないんでしょうか?

この -11 には 2.2.3 から 2.2.8 までの間の脆弱性に対するパッチなどが入っているんです。

なので「apacheの脆弱性対策などが最新版より遅れている」わけではありませんので安心してください。


CentOSなどでは通常、各アプリケーションはディストリビューションのリリースバージョン時のメジャーバージョンをそのままにして、後ろに更に独自の細かいバージョンを付けてセキュリティパッチなどを積み上げていくことが多いです。

こうする理由はメジャーバージョンが上がると機能追加なども含まれてくることが多い為、インストールベースが多いので、全ての環境で問題がないかどうかのテストが大変になるからです。

つまり同じバージョンのCentOSを使っている限り、勝手に新しいバージョンが入って既存の機能が動かなくなることを避けているのです。

大ざっぱな説明ですが大体そんな理由です。


アプリケーション自体が古くなってきて新しい機能を使いたいような需要が増えてくると、CentOS5.1、5.2というようにディストリビューションのバージョ上がることで対応するわけです。

id:chirubo

そういうことだったんですね。

分かりやすい説明ありがとうございます。

2008/05/02 19:21:36

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません