CentOS5にどうしてもMySQL4.0系をインストールしたいのですが、

ソースからコンパイルしようとしてもconfig.logに以下のように出て
configureできません。何か良い方法はないでしょうか?
---------------------------------------------------------
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure・・・

回答の条件
  • 1人10回まで
  • 登録:2008/05/03 14:30:39
  • 終了:2008/05/04 13:46:25

回答(1件)

id:catstail No.1

catstail回答回数13ベストアンサー獲得回数02008/05/04 01:16:54

ポイント60pt

基本的にMySQLはバイナリインストールが楽でいいと思います。

が、公式サイトを見たところ、4.x系は4.1しか残っていないですね。。。

MySQL :: MySQL 4.1 Downloads

http://dev.mysql.com/downloads/mysql/4.1.html#linux-icc

(普通の32bitCPUマシンなら、Linux (x86), Standard, 4.1.22 を使用)

もし、4.0が必須、ソースコンパイルが必須なら、ログの続きを見れば何かわかるかもしれません。

(上記のログでは、configureオプションやMakefileに何らかの変更が必要、としかわかりません)

id:ketaojp

その後、いろいろ調べて

# yum install gcc

# yum install gcc-c++

# yum install libz-devel

# yum install mysql-devel

を実行し、少しは先に進むようになりましたが、

今度は ./configureで

------------------------------

checking for termcap functions library... configure: error: No curses/termcap library found

------------------------------

と出て止まるようになってしまいました。

curses/termcapとはどこで入手できるのでしょうか?

2008/05/04 02:56:23

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません