あるwikiサイトを見ています。

wikiEngineはDeki Wikiのようです。

そこのメニューをクリックしてもIEだと正常に画面が遷移しません。
Firefoxだと正常に画面が遷移します。

※※※例※※※

文章タイトル:手順書サンプル
リンクをクリックした場合
IE動作→"http://※※※※/"へ再描画
FF動作→"http://※※※※/手順書サンプル"へ遷移

リンクを右クリックして新しいページとして開くを選んだ場合
IE動作→"http://※※※※/手順書サンプル"へ遷移
FF動作→"http://※※※※/手順書サンプル"へ遷移

最近見たページのリンクをクリックした場合
IE動作→"http://※※※/index.php?title=エンコードされたタイトル&bc=1
IE動作→"http://※※※/エンコードされたタイトル

上記内容でわかることはあるでしょうか?
ご教授お願いします。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2008/05/21 09:42:18
  • 終了:2008/05/26 17:52:46

ベストアンサー

id:ha_tenu No.1

ha_tenu回答回数12ベストアンサー獲得回数32008/05/21 12:16:30

ポイント70pt

あまりお役に立てないかもしれませんが、自宅サーバーでDeki Wikiを構築しているので、そちらの環境で確認をしてみましたが、zabineさんが確認されたのとは挙動が違っており、いずれのパターンでリンクを開いた場合でも、IE, FireFoxともに画面は正常に遷移しました。

その際、URLはすべて"http://※※※/エンコードされたタイトル"という形式になりました。

確認した環境です。

  • Server:
    • Apache2
    • PHP5
    • MySQL5
  • Wiki:
    • Deki Wiki 1.8.3 RC2
  • ブラウザ:
    • IE 7
    • Firefox 2.0.0.14
  • OS
    • Windows Vista

index.php?title=xxxという形式はDeki Wikiの標準設定では取られないはずなので、Wikiのサーバー側でそのあたりの設定がうまく出来ていないのかもしれません。

このmod_rewriteに問題があるとすると、サーバー側の問題でユーザー側からはどうしようもないかもしれません。Deki Wikiではないのですが、phpのページでmod_rewriteを使った際に、PHPだと遷移がうまくいかなかった事例がありました。

僕のサーバーのDeki Wikiは下記のURLになりますが、こちらの日本語タイトルのページにアクセスしてみた場合にはどうでしょうか?

http://yakitech.mine.nu/

再現しないようなら、サーバー側依存の問題のように思います。

id:zabine

http://yakitech.mine.nu/

↑↑↑教えていただいたサイトを見るとIEでもFFでも正常に表示されています。

そして、右クリックして新しいウィンドウを開いた場合でも"http://※※※※/手順書サンプル"ではなく

%e8%89%af%e3%81%8f%e6%9c%89%e...と表示されています。

私が見ているサイトは日本語のままです。ここに問題がありそうですね。

管理者の人(社内)もわからないと言っていたので困ってしまっていました。

ヒントでもわかったような気がします。ありがとうございます。

2008/05/21 14:07:54

その他の回答(1件)

id:ha_tenu No.1

ha_tenu回答回数12ベストアンサー獲得回数32008/05/21 12:16:30ここでベストアンサー

ポイント70pt

あまりお役に立てないかもしれませんが、自宅サーバーでDeki Wikiを構築しているので、そちらの環境で確認をしてみましたが、zabineさんが確認されたのとは挙動が違っており、いずれのパターンでリンクを開いた場合でも、IE, FireFoxともに画面は正常に遷移しました。

その際、URLはすべて"http://※※※/エンコードされたタイトル"という形式になりました。

確認した環境です。

  • Server:
    • Apache2
    • PHP5
    • MySQL5
  • Wiki:
    • Deki Wiki 1.8.3 RC2
  • ブラウザ:
    • IE 7
    • Firefox 2.0.0.14
  • OS
    • Windows Vista

index.php?title=xxxという形式はDeki Wikiの標準設定では取られないはずなので、Wikiのサーバー側でそのあたりの設定がうまく出来ていないのかもしれません。

このmod_rewriteに問題があるとすると、サーバー側の問題でユーザー側からはどうしようもないかもしれません。Deki Wikiではないのですが、phpのページでmod_rewriteを使った際に、PHPだと遷移がうまくいかなかった事例がありました。

僕のサーバーのDeki Wikiは下記のURLになりますが、こちらの日本語タイトルのページにアクセスしてみた場合にはどうでしょうか?

http://yakitech.mine.nu/

再現しないようなら、サーバー側依存の問題のように思います。

id:zabine

http://yakitech.mine.nu/

↑↑↑教えていただいたサイトを見るとIEでもFFでも正常に表示されています。

そして、右クリックして新しいウィンドウを開いた場合でも"http://※※※※/手順書サンプル"ではなく

%e8%89%af%e3%81%8f%e6%9c%89%e...と表示されています。

私が見ているサイトは日本語のままです。ここに問題がありそうですね。

管理者の人(社内)もわからないと言っていたので困ってしまっていました。

ヒントでもわかったような気がします。ありがとうございます。

2008/05/21 14:07:54
id:redwing1 No.2

redwing1回答回数541ベストアンサー獲得回数32008/05/23 01:43:07

IEが古いんですな http://www

id:zabine

IE7でもだめでした

2008/05/23 10:25:08

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません