Fedora8 + DDNS環境に、Rails2.1 + Phusion Passenger でWeb公開してみました。

※ httpd.conf で、"RailsEnv development" を指定しています


ブラウザでページを見ようと思ってURLを打つと、正しい表示になる前に、必ず真っ白なブランクページが表示されてしまします。(リロードすると、正しい表示となります。)

どなたか同じ症状を確認された方はいらっしゃいませんでしょうか。また、解決方法がありましたら教えていただければ幸いです。

よろしくお願いいたします。

回答の条件
  • 1人2回まで
  • 登録:2008/07/01 22:58:06
  • 終了:2008/07/08 23:00:02

回答(1件)

id:taku_j_7 No.1

taku_j_7回答回数139ベストアンサー獲得回数122008/07/02 12:08:40

ポイント60pt

症状は確認できてませんが、ログには何か記載がありませんでしたか?

一応、デバッグログまで出してしまって、原因の特定を行った方が早いと思います。

他は・・・。

・設定したエンコードと差異がある

・railsのプロジェクト不在

・実行ファイルのみでライブラリが不在

 ⇒cp /usr/local/src/passenger-1.0.1 /usr/local/lib/ruby/passenger

ログが気になります。

id:gets_itai

下でいただいた質問にて、ログについて記載しました。

2008/07/02 13:05:33
  • id:g_maeda
    - ブランクページが出たときのdevelopment.logやApacheのerror_logには何か出ていませんか?
    - ブランクページのHTMLはどんな内容でしょうか。
    - ブラウザではなくwgetなどでページを取得しても、やっぱりブランクページになりますか?
  • id:gets_itai
    ▼development.logに吐かれている内容は、ブランクページの場合と、(リロードして表示された)正しいページの場合に差異はありませんでした。

    ▼apacheのエラーログには;
    [Tue Jul 01 23:08:46 2008] [error] [client xx.x.xx.xx] Premature end of script headers: new, referer: http://www.sample.com/products
    /usr/lib/ruby/gems/1.8/gems/actionpack-2.1.0/lib/action_controller/request.rb:269: [BUG] Segmentation fault
    ruby 1.8.6 (2008-06-20) [i386-linux]

    と出ていました。

    ▼ブランクページのHTMLは、完全に空でした。

    ・・・ということで、バグなんでしょうか?



  • id:gets_itai
    なんか、自然に治ってました。アップデートも何もしてないのに。。。へんなのー。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません