【パソコン】あるソフトをインストールする際に「NET Framework 2.0以上が必要」と表示されたので3.5をインストールしました。[プログラムの追加と削除]の一覧で見ると、以下のようになぜかバージョン1.1から3.5まで入っています。これらはすべて必要なのでしょうか?最新(3.5)もの以外は消しても構いませんか?



・NET Framework 1.1
・NET Framework 1.1 Hotfix
・NET Framework 2.0 Service Pack 2
・NET Framework 2.0 Service Pack 2 Language Pack - JPN
・NET Framework 3.0 Service Pack 2
・NET Framework 3.0 Service Pack 2 Language Pack - JPN
・NET Framework 3.5 Language Pack SP1 - 日本語
・NET Framework 3.5 SP1

回答の条件
  • 1人3回まで
  • 登録:2008/10/21 08:48:24
  • 終了:2008/10/28 08:50:02

回答(4件)

id:ytakan No.1

ytakan回答回数831ベストアンサー獲得回数642008/10/21 09:27:00

ポイント35pt

http://ja.wikipedia.org/wiki/.NET_Framework

各バージョンは上位互換性が原則としてある。

しかし、1.1から2.0へは一部が上位互換性がない。2.0以降は上位互換があるとされている。

1.1は残しておいた方がいいかと思います。

id:fugang No.2

fugang回答回数11ベストアンサー獲得回数02008/10/21 11:21:07

ポイント35pt

http://d.hatena.ne.jp/himadatanode/20080207/p3

同じように試みている方がいました。

回答者1も明記しているように、1.1は残した方が良いと思います。(リンク先は使わないので消してますが)

そしてリンク先を参考にする限り、アンインストールの「順番」には気を使った方が良さそうです。

日本語パッケージを先に削除し、その後本体を削除という順番のようですね。

そんなん自動でやってくれっていう話ですが。。

id:Magical-Soft No.3

ごえもん回答回数19ベストアンサー獲得回数02008/10/23 20:26:09

ポイント10pt

仕事で.NET使ってますが、その環境でJ#(.NET版java)などを使っている場合は、J#のバージョンに気をつけてください。

あと、ASP.NETなどのサーバーを利用する場合も、できれば下位バージョンも入れておいた方が無難です。

http://www.atmarkit.co.jp/fdotnet/

id:minotiiku No.4

minotiiku回答回数3ベストアンサー獲得回数02008/10/27 22:39:44

ポイント10pt

http://msdn.microsoft.com/ja-jp/library/cc825635.aspx

http://msdn.microsoft.com/ja-jp/library/47a587hk.aspx

上の方々の書いてある通りです。

MSDNには上のような資料がありますね。

  • id:BaBo
    そのインストールしたいあるソフトは2.0以上を必要としている訳なので、そのソフトのためだけなら1.1は不要なのでは。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません