RPMを間違えてアンインストールしてしまったので、再インストールしようとしたら

下記のエラーが出てきました。。。

error: sorry rpm requires libz.a or libgz.a (from the zlib package)

libzが無いと言われているように思えますが
どの様に対応すればよろしいでしょうか?

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2008/11/30 19:50:29
  • 終了:2008/12/07 19:55:02

回答(2件)

id:goodvn No.1

goodvn回答回数228ベストアンサー獲得回数182008/11/30 19:57:58

ポイント60pt

以前,RPM を消してしまったというご質問に対し,私は回答をしました

http://q.hatena.ne.jp/1227637879

tarボールにある INSTALL というファイルを読んでインストールしてください,と書いたと思いますが,INSTALL はちゃんと読まれましたか?

./configure コマンドを打ち間違えてるところを見ても,きちんと読んでるとは思えませんでした

このファイルの中に,きちんと書かれている(それもかなり先頭の方で)のですが,それを試してもダメでしたか?

また読まれないかもしれないので,該当部分を引用しておきます

The zlib library for compression support. You might also need/want

the zip executable for java jar dependency analysis. All available from

ftp://ftp.freesoftware.com/pub/infozip/zlib/


さらに,下のほうに,

Note: rpm-4.0 on Red Hat 7.0 is currently using

zlib-1.1.3

db1-1.85

db3-3.1.14

bzip2-1.0.1

gnupg-1.0.2

You may use the tarballs within those packagese, and examine the patches and

spec files for details about how to build the libraries needed by rpm.

とも書かれています.もし,zlib が解決しても,またトラブルに合うかもしれません

アプリケーションを入れるということは,アプリケーションに付随したドキュメントには全て目を通し,理解する必要があると思いますよ

id:niwa-mikiho No.2

niwa-mikiho回答回数508ベストアンサー獲得回数382008/12/06 04:10:42

ポイント10pt

yum なり apt なりなんなりを使ってください

また OS を CD/DVD からインストールしたなら、その中に入ってます。

FTP から持ってきたのなら FTP にあります。

パッケージマネージャなら普通は関連とか見ながらインストールしてくれるとは思いますが・・・


http://www.google.co.jp/search?q=linux+%E3%83%91%E3%83%83%E3%82%...

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません